Not removing dirt when building roads



When I order my hearthlings to build a road, they no longer remove all of the dirt first. They remove most but leave at least a few.

Steps to reproduce:

  1. Build a road. At least 20 blocks in size should produce at least 1 bugged area.

Expected Results:
Bug free road.

Actual Results:
Blocks flash between dirt/grass and road.

Probably happens with floors as well. I believe it is due to the new multi block building from alpha 19.

Example 1
Example 2

Version Number and Mods in use:
Alpha 19 Release 687
No mods

System Information:

Block Clipping [A19]

Hey there @logan, welcome to the Discourse :smiley:!

I just tried to reproduce this, but couldn’t. Are you sure it happens simply by building a road? Could the road possibly be intersection something else?


So It only seems to happen on the roads I am laying around my city walls. It can’t be intersecting anything because the walls are freestanding with no foundation. The link contains the save.



Awesome, thanks. I’ll look at this tomorrow.


So I don’t know if this helps but I actually started building those walls and roads in Alpha 18, closed the game, it updated to Alpha 19, and that’s when it started happening. The part I built before that was fine. I will probably start a new save now that 19 is out. If I notice it happening in the new save I will let you know.


I think it’s a race condition or something, because it’s tricky to reproduce. I managed to get this:

But I’m trying to find better steps and I can’t reproduce it again. I’d say this has happened sometimes even before the multi-block feature.


I have been getting the same thing with a few blocks that should have been excavated. So far it’s only from the digging from the road tool. Then I ran into the “Can’t select a single block to delete it” bug and which then follows up with another strange bug that when a single block is placed, 3 hearthlings run up and place 3 blocks in a single block. Something is a bit wonky. I believe the dig/delete tool thing was fixed recently though. I’ll try on another game to see if it works better now.


I had that happen in the game I’m now playing with Raya’s children. I was able to click on the row, it happened at the end of the road. So I destroyed it thinking that the row would be the only place destroyed but it destroyed the whole road. When I rebuilt the road it didn’t happen again. I didn’t report it because I thought I made a mistake when I built the road since I was able to select the row it happened in.


One thing I’ve noticed, is that while building long roads (usually those that are more than four or more blocks wide and 20+ long), it seems like some pieces of the ground will not be mined out before a block is placed down. This seems to be a result of the new building system where more than one block is placed at a time during construction, as if there is a piece of unmined ground next to a spot a Hearthling is going to build on; instead of being built around or skipped for the time being, the block is placed down in the already-existing ground piece.

Here is a screenshot of this such occurrence:


I wanted to add to this because I used to experience this but it stopped around Alpha 20 but recently I have been seeing it again.

In this case it’s worse because its a stretch of 4/5 tiles not just one.


Apon closer inspection it appears to be 7 tiles, also it is a free standing road and is not directly next to anything as I like to leave a one block gap of grass between roads and structures.