Not able to use the maximum amount of Engineer turrets?

Hey guys, first playthrough with A17 and I’m not sure if this is a known bug or something I’m experiencing alone, but my Engineer will only place two turrets as opposed to the four that it says he can place.

Is there a fix for this? I’ve tested it with every type of turret, restarting the game, and yes I 100% only have two turrets placed.

Just as an update, it seems that the Ballista isn’t working at all either.


Hi @Minisynn! First off, welcome to Discourse! :slight_smile:

I ran into this same problem recently, and @linda was able to help.

First question: Are you playing a game that was started fresh on the latest stable release, or is this a game that was started on a prior version of the game?

Brand new game started on A17 with a batch of updated A17 mods installed.

I managed to fix the turret problem by going into the JSON file and upping the turret count at each bracket by 2.

The ballista still isn’t working though, and it has no icon!

Just because I know Team SH will ask, can you check to see if a fresh game without mods has the same problem? I don’t know if you need a fresh game, or if just disabling the mods temporarily will be enough, but on the safe side, a vanilla world as a test would probably be best.

Ehh, it takes a long time to get a Blacksmith and Engi fully locked and loaded.

Is there any way to cheat and create a max level engi and BS in a fresh world for the sake of testing?

Yes. Though considered a mod itself, they’ve built a mod called Debug Tools which allows for this, and they do support its use along side an otherwise vanilla world when bug testing. For the sake of testing, I’d level them up and give them the resources to craft stuff, but I’d avoid spawning in the Engineer’s items themselves, just to make sure the game engine itself is working as intended.

Debug tools:

Ah cool, thanks for that!

I’ll post my results tomorrow. Hopefully it’s just a mod messing with something as opposed to a problem with SH.


Hi there!

What level is your engineer? At level one, he should indeed only be able to place two turrets (and four traps) and at level three it becomes four turrets and eight traps. We don’t have a ballista in the game, so i’m guessing you mean either the turnip shooter or turret. So does it not shoot when enemies pass by? It could possible that the enemy is not in the line of sight of the turret, in which case it will not attack.

Can you upload a save so I could take a closer look?



Hey Linda.

Sorry for the delayed response, been out and about for the past few days.
The ballista that I was referring to must have come from a mod - my mistake!
In regards to the other siege weapons, the Engineer is level 6. From levels 1-5 before I changed the files he was only able to drop two turrets, and at level 6 he is only able to drop 3. Even dropping turrets past two frequently causes issues, and the Hearthlings just refuse to place them.
I can’t attach the file currently, as I won’t be back at my home PC for a few days but if it might help someone else with this issue I’ll happily upload the file then.

Cheers for the response!

A save would be helpful for diagnosing what’s causing problems with the placement limit. When you click on the unit frame of an iconic or placed turret, what does it say under Turrets placed? It should look something like this:

Also, what mods are you using?


Placing objects in general seems to be extremely low in the overall priority scale these days. This becomes especially apparent at the later stages of game play, when you’re up past 24+ hearthlings and there’s a larger quantity of subsistence farming necessary to keep the food score high. It’s possible that’s a contributing factor here as well?

If you wait long enough (many game days/possibly a week+) do they eventually place it? I guess I should also ask if you’re able to place the ghosted version of the turret, or if the UI telling you you’re at capacity already.

I am having this issue in my current game… My engineer is lvl 5 and i have two turrets placed, but it says i have 4.
Before reaching the good turrets i had two turnipshooters placed, but i removed them before placing the two turrets i have now.
Its not gamebreaking for my defence of the town, but its annoying designwise…

1 Like

Out of curiosity were the 2 turrets that were placed part of a building, or ended up getting attached to one? I’ve had this problem before as well. I think I ended up having to destroy the building the turrets were attached to or the turrets themselves. Been a while…

ah yes good point. No is the answer. I placed them intentionaly on the bare ground so they would not get in conflict when i reached the better turrets. But i guess the conflict, just in a different way, still happened :jubilant:

1 Like

What is show in your town inventory? Does it says it has 4 deployed turrets? And what happens if you remove those two and try again? (maybe update the counter)

ok the inventory showed 5 (i have one in reserve), i then tried to remove the two that was placed and it turned out that there was two turrets in each spot… So the hearthlings have placed the same turret twice and with the result that you couldnt see that there was two. Well it fixed the problem or the current issue in my game at least.


Did you placed them through the build menu?

Because items in a build will always auto-queue themselves when destroyed (like a broken door). I would guess that the build reordered a turret, and at the same time the engineer also reordered one (which is his job after all)

1 Like

yes they where placed on a building.

I just confirmed in a test world. If you have a turret in a building and it gets destroyed by the enemy (important, destroying through debug didn’t worked) an replacement will be order twice, one from the building itself and one from the engineer!