[NLA] Multiple Carpenter Stations


#1

Title: Multiple Carpenter Stations causes inability to control any aspect of game.

Summary: If you create two (or more, I presume) carpenter stations and, after assigning/promoting a citizen to use the first… if you are in any dialog screen while the citizen performs the acceptance ritual, you will find this dialog screen remains on the screen and will not be able to be closed.

Steps to reproduce:
Open game.
Create stockpile.
Order citizens to begin chopping trees/collecting berries.
Create Carpenter workshop (workshop A).
Create Carpenter workshop (workshop B).
Go to Workshop A; promote a citizen (Citizen A) to be the carpenter for the workshop.
Go to Workshop B; before Citizen A has begun the acceptance ritual, start to assign a citizen (Citizen B) to the workshop.

Expected Results: I should be able to assign Citizen B to Workshop B and continue the game.

Actual Results: If, at this point, Citizen A begins the ritual before you have assigned Citizen B, the promotion screen will become locked on the screen; you will be unable to select a name for Citizen B. All items will remain selectable, but no interaction is possible. Essentially, game over.

Versions and Mods: Current Alpha. No mods.

System Information: Windows 8.1; AMD FX-6200 Six-core processor running 3.8 GHz; 16 GB memory; AMD Radeon HD 7570 video


#2

I see… This seems to be one of the bugs related with the UI. I think even happened to Tom in the livestream when he played the Alpha. Thanks for reporting.

Alternate title: “Can not close UI components, preventing the user to play”


#3

I also had this issue but when I tried to reproduce the bug the game worked fine see this thread for my video of the bug.

http://www.stonehearthguru.com/forums/alpha-beta-testing-nexus/support/bug-reports/50946-con-multiple-carpenter-bug#c1


#4

thanks for the report @KDLadage! :+1:

i’ve tossed your entry into the corresponding report on Curse…


#5