New builder problems :(


I love building in the new builder. But since Alpha 24.10, the builders has been acting wired for me.

When I’am building a finished template, there will be a red marker above the building saying I do not have al the building blocks that I need ( for example window frames). The Hearthlings will not build even when i have gat all the requirements in a stockpile. After haf a hour of building, I wanted the building to be complete so I used the “ib” command to build it, but all the scaffolding didn’t disappear and i was unable to destroy it.

Since building is a big part of this game, and i didn’t have any problems before, I wanted to share my experience.


Did you try pliers? :'D Ehm… sorry.

No, I completely agree. Some of the templates have trouble building, especially the converted ones from the old builder have trouble with getting finished after this update. List of stuff needed for construction does not display things properly, but I remember that has been reported… Some time ago. The construction sometimes shows the exclamation mark without the process stopping and accessible areas mark as inaccessible - red, even with ladders leading up to them. It’s kinda hard to report on that though, when it resolves itself (kinda) or the construction just goes on with no more trouble.

IB is broken now :expressionless: My buildings then get finished without windows. You should not use it for a build that is in progress, it won’t remove the scaffolding. The command (something like remove_scaffolding) did nothing as well.

Destroying a huge structure also often leaves floating windows behind.

Oh god… so many reports to make…

1 Like

Happend to me yesterday. I’ve planned a building, should look like a cross sign from above, for my healer. So they’ve build it up to 80%, till a merchant visited me and i’ve stupidly sold too many high windows. So in the end, carpenter’s list was already done, but needed windows weren’t taken from storage for construction site.
So result was, i tried “ib” to finish, but scaffolding still remained inside and some of it outside the building, looked very strange. Useless building…:thinking:

1 Like

you can simply make more windows on your own without instant build, as soon as more hit storage, they start placing them.

1 Like

That step i stupidly tried after my fault :grin: doesn’t work. but i may try next time ,thx.

I had windows, orderd new ones. The potter made new ones. They still would not continue building.

Thanks for the bug report! If you can upload a wonky save, that would really help with debugging. Otherwise, it’s hard to guess what might be wrong. :stuck_out_tongue:


Problem with missing windows solved…
What happened:
i wanted to upload my “wonky_save” for you, but i saw it was before the merchant arrived.
So i started yet, with this savegame, but no merchant arrived till my hearthlings finished the “cross” building. After last window was placed, the ladders and scaffolding disappeared and all went fine. My hearthlings celebrated the new building. :tired_face:

So for future: it’s better to have more than one savegame, to recreate stupid situations :wink: