Multiplayer 2 players 1 banner

I was second player connected. After placing my banner, another player joined (player 3) as I was leaving. Then Host destroyed my belongings and I couldn’t join the game. Host send invite and i can join, only to see that i now control the same hearthling as player 3. I’m not in the player list but I can interact and do everything with thoses hearthlings.
Then we chose the name and banner of our city and our 5 hearthlings suddently dissapears and are marked “out of town”

Steps to reproduce:

  1. Host launch MP game
  2. Second player join
  3. Third player join
  4. Second player leaves
  5. Host Delet player 2 belongings
  6. Host invite player 2
  7. Player 2 joins and can play with the same hearthlings as player 3.
  8. Wait for banner upgrade
  9. All hearthlings are now flagged as “out of town”

Expected Results:
Player 2 Joins the games and can place another banner and start over.

Actual Results:
Player 2 Doesn’t place another banner and controls player 3 hearthlings.

Just to say, the bug was hillarous and two players controlling 5 hearthlings was really fun.


I only have this screenshot since I didn’t take any when we still had hearthlings.

Version Number and Mods in use:
r838 build x64
Mods :

System Information:


Now this is quite the problem.

After our first game, We tried another game and I was the third one to connect. When connected, the host saw player 2 connected (there was already a player 2 in game) and i could play as player 2 with the actual player 2.

When player 2 left the game, The steam icone changed, then the name of the player changed.

(I have two screenshots of the name changing)



Player 2 disconnected (The two player controlling player 2) and Host deleted the bellongings of player 2.

I reconnected as player 3 and could place my banner as well as player 2.

The bug was resolved with this.

Wait you can play multiplayer?

Thanks for the report and detailed repro steps. We’ll take a look!

@Nikolai_Kingo yes, multiplayer is available on the Steam Unstable branch (“latest”).


this might be the issue (and why) i have it as well > [Determintation] Hearthlings get Married!

I think what is seeming to happen… as soon as we destroy another player (kick them and destroy their spot in the list) if another person joins then some reason the marry

I say this, because i kicked a player from my game today and it happend after… and then the other time it happended last week, i had already done the same kicked a player fully… someone joins… and marries a hearth

This must be it?

1 Like

Yeah, poor @YMIHere. I wouldn’t want to be married to me, either. I’m a handful and a half.

1 Like

Congrats on @Averest and Vexris

ok so… These guys got married today (shared their hearth)

When @Averest tried to join it said i was full but i had one spot left… and when she could join it said vexris was connecting even though he was already connected… and when @Averest joind, she doubled with his hearth… when she left, Vexris hearthlings left

When’s the honeymoon guys? :stuck_out_tongue:


1 Like

As an addendum after failing to connect, I had not exited fully out of Stonehearth I went to the main menu.ConnectiingError


And after, we relog on the server and we were always on the same player.

EDIT : no mod in this game


ok so many relogs seemed to fix this… we never knew divorce could make us so happy :stuck_out_tongue:

Would you be able to post a save file for me? It might help me figure out what happened!

1 Like

i think i still have the file… will have to find it, but later… will report back if/when i do @ayazar

1 Like

judging by the thumb this should be the one (and the hearth in question is in the thumb) @ayazar

1 Like

Thank you!

1 Like

This has happened once again… we had played (on and off) for about 5-6 hours in this game… and once @YMIHere joined he becaume married to @Spell_Blade - she could not controll her hearthlings but @YMIHerecould, this persisted until he logged off… which also diconnected @Spell_Blade - but once she came back (on her own) she had control once more

You already have the previous save @ayazar - would you need this one as well?


difference is… this is now in latest build and is obv still happening

We’ve found it! The fix for this will go out with the next push to the Steam Unstable branch (“latest”) :smile:


but i so wanted to mary @Averest qq :stuck_out_tongue_winking_eye: