[MOD] Roll For Need - loot mod


Well everything seems to be going well
This was my encounter the molten fire lava golem

the golem was nice enough to leave me this sword

Which I was able to find a good use for

The Goblins got the point and could not stand the heat


:grin: good to see it’s working, very lucky to get that on your first encounter with the magma golem. Also in the interest of balance when you were up against the golem, did it feel too difficult or too easy? Was this quite far into a game or not? Does the molten sword feel overpowered?


At the time, the encounter occurred rather late in the game, and it was a little too easy, I had a population of 29 and 9 of them were Soldiers , 1 knight, 2 footman, 3 Clerics and 3 Archers and I had them in decent gear from the yang mod @Yangzhoui (gladiator armor for archers) and Dark Knight, Paladin and White Mage armor from Final Fantasy Jobs @Reyn So this also had a great effect on the battle. I believe it would have been significantly harder at an earlier stage and running the vanilla version. I was wondering if there is a mechanic that could scale the encounter, such as adding minions or increased MOB damage and resistance base upon the players military value. At this point in the game the sword was still the best weapon in the game, but due to size and composition of the Kobold and Goblin armies it was not that overpowering, if acquired very early in the game it should be considered a siege weapon.


How do the patterns work, as far as getting your crafters to learn them?


It as simple as finding the recipe scroll for that item once you have it, it will unlock the recipe for the relevant crafter. You should receive a notification when you find one and the recipe is unlocked.


Ok, I have several, just haven’t noticed any new items.


Oh when mentioning the scrolls @The_M. The png of the scrolls in the vendor windows is not working correctly. Other than that, great mod!

Thanks. :slight_smile:


Did you start a new game after installing the mod? If not the recipes won’t unlock.


I’m really excited to be trying this mod, I haven’t found any of the encounters yet, but when I do … :smile::smile::heart:


Yes I did, I have other mods running. Not sure if any interfere yet.


No other mods should interfere unless they override the recipes of the crafters. If you upload a copy of your save file I could take a look.


You might be able to figure it out from your stonehearth.txt log file that is in the same directory as your stonehearth.exe

Do you think you could find and post that?


It was in fact a mod that was messing things up. Had an older outdated mod that “technically” worked but I probably should have stopped using along time ago.


Never mind i just got my answer lol


could you make a spoiler list of items in the description? for collectors purposes


Ok I have added a spoiler list of all the weapons and armour that can be crafted or found.


Cool, now its like pokemon. Gotta collect all the items.


The recipes are not unlocking for me. They did unlock once, when I first installed stonehearth and my mods, but now they don’t work at all. I am getting the scrolls, but nothing happens after that. Tried reinstalling, new saves, running only roll for need, etc. If I use the search bar, I am getting the recipes (all, including ones I don’t have the scroll for).

Also, I am getting an odd bug where sometimes, the hearthling going to harvest the holy water ends up stuck next to the altar, without harvesting it. Just stands there, spazzing out. This doesn’t happen all the time, and a reload fixes it.


I’m not sure why you would get the issue of items not unlocking after reinstalling, but there was definitely an issue with items not unlocking after loading a game (this is what I get for only testing in micro worlds :man_facepalming:). This was basically caused by the item listener that keeps track of the inventory to see if you get any recipe scrolls not being activated after loading a save. This has been fixed now. As for locked items becoming visible when searching, that is a bug with Stonehearth reported here.

I also noticed hearthlings sometimes getting stuck with the sacred altar, the collision box was a little too large so I have reduced it, hopefully that shouldn’t happen anymore.

Give the new version a try and if you still have issues with items not unlocking let me know.


am I correct in my understanding that this mod requires a new game to be started with the mod enabled in order for it to work? if so please add a disclaimer to the OP