[MOD] Piles Plus v5.0 (The SH 1.0 update!) 📦

Hi @nikosthefan, it’s really a great mod. :kissing_heart:

I have 2 suggestions here:

  1. Remove the prefix [Add][Object] of the mod. It will make the stamp tool (from dubugtools) not able to stamp those new items. Or it’s the other reason causing this problem?

  2. I think the ingot piles shouldn’t overlap to each other.

Thank you. :smile:

I have no trouble stamping things from my mod. I start with [ and it works. Also, every space in the name has a _ in between and the address of a rack of pelts is called pelt_rack. All things that could cause the trouble.
scratch that, I have no trouble at all. When I type in pelt for instance, I get a list of all the pelts in the game, as well as the pelt racks from my mod.

On point 2. I already noticed that, and I am working on a solution. Fixing it is part of the clean-up work coming up.

Hmm… That’s weird. The item list is working fine, but when I select one of them, it refuses me to stamp. :frowning:
Image 3

Image 4

To be honest, I have never seen that problem before, and have no clue what it is or how to fix it. Sorry :disappointed:.

That’s fine. I’m looking forward the updates. :grinning:

I was always confused with the piles that require a particular item to build

How does that work? When you make one, how can you use the material again?

I made some wood and stone piles once, I could never find a way to use the stone, and this mod has motivated me to start using them

How do I use piles? (I have the better stockpiles mod, but these “material made” stockpiles confuse me)

Put them on the ground, and harvest them.:wink:

1 Like


So, just like if they were trees?

Yes, just like the way you harvest trees, but this time they are material piles.

They are harvestable when putting on the ground.
Image 1


For whatever reason, I’m unable to find any instructions as to how to install this. Since there is no .smod file here, I’ve had to try to alter the filetype of the zip folder to a .smod file, and compressing it and changing the .7z file into a .smod file, but none of the things I’ve tried have worked. Could I get a bit o’ advice, perhaps? Since the idea of having a compressed, VISIBLE storage for materials really appeals to me- imagining vaults filled with piles of gold and silver. As for ideas for other piles… Perhaps piles of…
Clothing? Potions? Jerky?
Or a few absolutely stupid ideas that would serve no point other than to highlight how truly mad a player is… like piles of chairs, windows, workbenches, or tools.

Or, truly the most mad of all ideas. Piles of piles. I’d imagine you’d need to clear out quite a lot of space for one of those monstrosities, but just think of how satisfying it would be to load in and see a pile of eighteen gold ingot piles, each containing eighteen gold ingots apiece…

hello @xenostiger,

yes, the format of the download is a little odd.

the easiest way to install the mod would be to extract the zip.

The extracted contents will probably be a folder called [Add][Object]Piles_Plus. Within that folder is likely another folder called [Add][Object]Piles_Plus. Copy this second folder (and all of its contents) into your Stonehearth/mods/ folder.

Your Stonehearth/mods and Stonehearth/mods/[Add][Object]Piles_Plus folders ought to look kind of like this after:

I hope that helps!

Mod folders work when they have the extension .smod, but also when they are compressed files (.zip) or when they are just normal open folders.

I know the last one is true, because I use that for developing the mod. I tweak, and I restart the game to see the changes, but I do not go trough the effort of making it into a .smod everytime (imagine that :confounded:).

As for the .zip’s.
.zip’s are the true identity of .smod’s, you can use that trick to see inside (and thus
to mod) the .smod folders. You just rename mod.smod to mod.zip, ignore the warning your computer gives you, and extract the entire contents of the mod in a normal folder. It works.

When I packaged the mod for download, I simply compressed all the mods content from the normal open mod file into a compressed file (.zip), and put that file into the forum thread.
All you need to do is take the folder you’ve downloaded, and place it among your .smod’s. If you reallly want a .smod, then change the extension.

@nikosthefan, I think you are suggesting that the downloaded file can be renamed to have a ‘smod’ extension.

That works, in theory, except that many folks do not have the “show file extensions” feature enabled, so they’ll end up inadvertently renaming the file to [Add][Object]Piles_Plus.smod.zip, which the game won’t load (Stonehearth doesn’t load files that have ‘.zip’ extension).

1 Like

oh, it doesn’t, interesting :thinking:. I will change it to a .smod then.

When i mark a mod in list, marking disappearing and mod don’t work .It appear only for two mod: your and clearsky. I use a lot of mods, and think that know a lot, but may be not see something obvious. Help me, please =)

1 Like

Probably caused by the symbols in the mod name.


You right! After renaming [Add][Object]Piles_Plus.smod to Piles_Plus.smod, and rewrating minifest-file i can start mod but with 30 warnings and wtihout images.
Need rewrite all recipes at “Piles_Plus.smod\Piles_Plus\jobs\blacksmith\recipes"
in line “item”:”[Add][Object]Piles_Plus:tin_ore_pile" to “item”:"Piles_Plus:tin_ore_pile"
30 times… 1 time for 1 recipe…

I have the same problem, I think symbols in mod names are not tolerated by the engine.

@EregionChannel: there’s always Notepad++ with its batch replace function :wink:

If it is indeed true that the symbols aren’t tolerated, I will change it
when I get back to finishing the mod. I know what to do, and I finally have
my new computer now, but I will be busy with college this week, so it will
have to wait a little more. I will also fix ClearSky at that point.


Can we move this out of current mods? it’s been broken for over 2 months