[MOD] ClearSky mod v1.1 ☀ (reupload)

ClearSky Mod v1.0

This mod will disable your clouds while installed. 'Nuff said.

The idea came from @Kodi4444 in this thread, the way of implementation (and some bugfix help) came from @max99x.

Download v1.1
All my mods can by found at my stonehearth mod repository.

Updates from v1.0

  • Removed weird symbols from the mod name which were causing annoyances.

Enjoy your clear skies. :sunny:


Goddammit, dude! It`s really great mod!
I hate when i see shadow from clouds in my caves every couple of minutes!


Glad you like it.

I quite like the clouds myself, but when @max99x came with a way to do it, I thought “hey, that is easy to mod”, so here we are.

Thank you! Surprisingly well appreciated, if just for when I play on my desktop (which is not the most powerful machine anymore)

1 Like

Update ClearSky Mod v1.1

I changed the modname in this one, so that it wouldn’t get unselected unwantedly in the mod selections menu.

Download v1.1
At the first post.

Updates from v1.0

  • Removed weird symbols from the mod name which were causing annoyances.

Enjoy your clear skies. :sunny:


smod file has string of numbers as name please re upload or provide new link thanks


Does this have anything to do with this:

Because I didn’t do weird things with the modname. The name you see in the first post is the name you get.


He means your file is hosted as 4ba8c90380305d3a7c1957e4bb47cba3d4409728.smod and as such will not work as that is not the mod name. It is not named ClearSky.smod anymore.

1 Like

I don’t know wether/how I can fix that.

You can simple upload it elsewhere and paste the link.


I think I will do that, then.

Thanks :slight_smile:

its an actual issue with discourse - normally it shouldnt transform the name - so in some days it should be fixed ^^


mmmm… don’t know if it is the same with other people but still giving me numbers.smod
thanks for trying to correct it

Did you rename it?
I manage to fix mine with renaming it to “ClearSky.smod”


I followed @BrunoSupremo’s advice and uploaded it via Github. Tell me if this fixes the problems with the mod names.

Edit: fixed the link

A24 Unstable steam branch - mod not work - i see a motion of sky

hmm, I do not know what that is. I don’t have the unstable branch myself, but considering the simplicity of this mod, they must have changed either the name or position of the cloud texture, changed the way clouds work or the way overrides work.

You can debug this for yourself, a bit.

  • go to your directory explorer
  • enable file extensions, so you see what you’re doing
  • go to stonehearth/mods/ and find the clearsky mod.
  • rename it from .smod to .zip
  • unpack it
  • right beneath you find the manifest.json
  • open this in your favourite text program.
  • You see one override. On one side, you find the file path in stonehearth.smod it tries to override, on the right hand side, you find the file it tries to replace the other file with.

What you need to do is copy and open stonehearth.smod as you did with clearsky (the copy is as prevention measure, so your not looking into/messing with the copy the game tries to read), and see if the file path in my manifest still leads to the file it says you’ll find in stonehearth.smod.

The answer to that question, I’d like to know.

you should add it to the steam workshop


I have just now made this mod public on the Steam Workshop for everyone to subscribe to.

I will also try to update and transfer my other mods to steam workshop in the coming days. All transferred mods will keep being available on the forums.