[MOD] Building Editor - From Microworld mod (A23)


#1

I updated Microworld mod from Stonehearth dev team to include a new world : Building Editor.

This allow players to build freely with all furnitures available in the custom build tool (every crafter is present and max level).

You will be able to build anything in a flat world without having to start a new game or go through the rooster and map selection.

To launch the mod use this command :
Stonehearth.exe --game.main_mod=microworld --mods.microworld.world=building_editor

Also, make sure you launch the game at least once to have saved_objects folder created before designing templates using the building_editor microworld.

Installation guide on Youtube : Stonehearth - Microworld mod - Building Editor

Mod link :

Let me know what you think !


Pure Creative Mode?
Building mode? (words for min. 15 character title)
Returned to see how things have changed - thoughts
Read every once in awhile
#2

Hi,
I added all furnitures at start, so now you can build with all furnitures available (flower, trophy, fine item, etc).


#3

Hi @nxor,

Very nice mod.

Can you add a supply of food so that the lil people will not starve while the mod is in use?

Also, I would love love love to be able to access this from the main game menu. Do you have that in your plans, is it possible?


#4

This is good! I used to have this function! This is more convenient for me to build the building


#6

When I go to place furniture, doors, windows, or signs there are no options. I can only door floors, walls (building and freestanding), steps, and roofs. I followed the YouTube tutorial on installation and use, I do not see anything that I did different.


#7

Nice mod Nxor!
The git clone command provided did not provide all of the required files to launch the editor - I was forced to use the zip download instead. Something needs to be corrected for the git clone steps.


#8

Sadly the fine items are gone from the menu after using the one piece you have. Is there a way to make them permanently added to the list?

This is extremely useful not only for buildings, but also to test model placement.


#9

release-758 (x64)[M]
c++ exception: lua runtime error
stack traceback:
[C]: in function 'create_entity’
radiant/modules/entities.lua:24: in function 'create_entity’
microworld/micro_world.lua:66: in function 'place_item’
microworld/micro_world.lua:451: in function 'place_all_entities_passing_filter’
microworld/micro_world.lua:485: in function '?'
radiant/lib/unclasslib.lua:381: in function 'place_all_furnitures’
microworld/worlds/building_editor_world.lua:44: in function '__user_init’
radiant/lib/unclasslib.lua:270: in function '__init’
radiant/lib/unclasslib.lua:201: in function 'script’
microworld/micro_world_server.lua:22: in function 'instance’
radiant/modules/events.lua:291: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
radiant/modules/events.lua:285: in function <radiant/modules/events.lua:251>

I got that error today, how can I fix this?

release-758 (x64)[M]
std::logic_error: 'Calling iterator method on non-iteratable: find’
stack traceback:
[C]: ?
[C]: in function 'load’
stonehearth/components/fixture/fixture_component.lua:10: in function <stonehearth/components/fixture/fixture_component.lua:6>

Also, that one


#10

I also dont seem to be able to place down hedges, and other “building parts” through the building editor, kinda weird since thats their sole purpose? I cannto place down picket fences, arches, and most things under “buildings parts” except windows and doors


#12

What file needs to be rewritten in order to increase the size of the world in microworld?


#13

It has been updated to A23.

Download the code from Github and enjoy !


#14

Thanks a lot @nxor, it’s perfect to test my mod !


#15

May I suggest adding all lvl 6 crafters to the building editor world?


#16

I thought they were all there already ? whom is missing ?


#17

Herbalist and Cook.


#18

Seems it don’t work with A23 R784 :frowning: I only have black screen and music.


#19

If you have a black screen, have you start your game once normally or it is a fresh install?

It happen when one of the folder is not created yet after a new install before starting the first time.


#20

Okay it works now, thanks ^^


#21

Works perfectly with uA24r789.


#22

so, since its 1.0 now, I tried launching it, but for some reason, mods wont load at all when I try to generate the world.

are there plans to implement this better?