Loot not being picked up

Hi @Colster, can you provide a few more details about what else is going on in your game? For example, are all of your Hearthlings doing other jobs (like building, crafting, eating, etc…), or are they just standing around? If you could upload a screenshot, or more ideally your save file and stonehearth.log, I am sure that @8BitCrab or @SteveAdamo will connect you with the right TR member for help.

Also, @8BitCrab or @SteveAdamo, this needs some tags, likely Support and Bug report, unless this is just a gameplay issue…


Hearthlings doing their jobs. Just finished up a new Stone mason building. Farmers doing their jobs. I assign a task to build they get it done. So I am not sure what the disconnect is with them getting the loot. There is some scaffolding that they left up on one of my buildings. Maybe they want to complete that and its causing issues. Not sure.

That is definitely strange. It is my understanding that looting has a pretty high priority in the AI, so I am not sure about this. Will need to wait for someone with a bit more knowledge than I.

you could also try
1 finishing up the building
2 looting one at a time. it seems to be easier on the system than mass looting

1 Like

hey there @Colster,

so your hearthlings dont have any other jobs to do? if they are mining, chopping trees, building, etc. if they are just idling when they should be gathering then this is most likely a bug.

try cancelling the order and the re-order it, as this might “reset” their AI which would help if its an AI issue.

1 Like

This is the bug that appeared after I reloaded, still not getting loot. If I build a building or a road or a wall etc…they accomplish the task. No loot gathering though. The only time they go to grab the loot is if I put them in a defensive party assign them to the area. Call off town defense mode. A few Heaths will grab a few pieces of loot for about 2 minutes but then go back to not going after it. I also have a building that has some scaffolding on it still. They wont take it down for whatever reason. Im thinking this screws with the loot gathering. Who am I to really determine that though. I have no Idea.

Also if there are no assigned tasks, my workers will go to a stockpile and just constantly pick up and re stack stuff. They just stand there pick up some blocks put blocks down pick them up again etc…

1 Like

one workaround for that is the destroy command,

  • open the console (left Ctrl + C)
  • select the thing you want to be destroyed (the scaffolding)
  • type in destroy and hit enter
  • close the console the same way you opened it.

these steps should work. though i would suggest saving before doing this, as it can sometimes cause errors.

That loot is far away. If your hearthlings are not busy, they might go and pick it.
I recently read Yang mentioning something like the loot function not using the right pathfinder or something, but maybe it was some dev builds ago…

Anyway it’s a valid bug. I think restocking has lower priority than other tasks, but I’m not sure how it’s the AI organized in the last build…


I had the same thing with loot that was far away, however i activated the new pathfinder and they picked it up after that. I guess the old one cant handle it when its so far away.

1 Like

How do you enable new pathfinder?

I think it’s with

"simulation" : {
		"use_subspace_pathfinder" : true

in your user_settings.json file. But people are getting bugs with it, so use with caution if you want to enable it.

1 Like

If your running the unstable A12 then its under settings and gameplay if i remember right.


Edited your post with the correct user setting.
Also, Yes to @Snooke. You can enable the new pathfinder under settings->gameplay and you can see it in the experimental section.


When I give them orders to loot , They do nothing.
is there any way to fix this by myself?
tnx guys

Hi @MichaelTraveler.

I’m not sure which workaround would work for looting items.
I remember @ponder on one of the last livestreams that was messing with the code because they are not picking up the loot.

Maybe you can try leaving all your hearthlings without tasks to do, and move them (with the party options) nearer to the looted items.

tried something like that and got that error :
develop-2630 (x64)
@stonehearth/components/crafter/crafter_component.luac:34: item with id 10798199 became invalid in the crafter backpack!
stack traceback:
radiant/modules/common.luac:46: in function 'report_traceback’
radiant/modules/common.luac:125: in function ‘verify’
…tonehearth/components/crafter/crafter_component.luac:34: in function ‘remove_first_item’
…tonehearth/ai/actions/drop_crafting_ingredients.luac:6: in function 'call_fn’
stonehearth/components/ai/execution_unit_v2.luac:22: in function '_call_run’
stonehearth/components/ai/execution_unit_v2.luac:198: in function '_run_from_started’
stonehearth/components/ai/execution_unit_v2.luac:141: in function '_run’
stonehearth/components/ai/execution_frame.luac:454: in function <stonehearth/components/ai/execution_frame.luac:454>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:672: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:454: in function ‘_run_from_started’

stonehearth/components/ai/execution_frame.luac:129: in function '_run’
stonehearth/components/ai/execution_frame.luac:358: in function <stonehearth/components/ai/execution_frame.luac:352>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:672: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:360: in function 'run’
stonehearth/components/ai/ai_component.luac:177: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>

1 Like

Hmm… that looks more like this bug:

(I’m sure it’s reported somewhere else, too). Maybe one bug leads to the other, who knows.

I think @ponder fixed the loot bug in the livestream, but he’s changing also other functionalities that create tasks and are similarly affected, so it could take some time until we get the fix. :disappointed_relieved:

Hey @MichaelTraveler a decent workaround is to place a crate near the loot then only loot around 6 or so items at a time. It takes some time though…

This happened to me, and this fixed it:

  1. Select the object that won’t loop
  2. Use ‘teleport’ on the console and move it (closer to your base is prob best) by clicking its new destination
  3. A hearthling then picked it up

Also, put the visual path thingy on so you know what’s in a hearthling’s head.