Launch bug, can't launch the game after exiting it for the first time


#1

Hi, I just bought Stonehearh yesterday (6th November 2018), haven’t tried it out until this morning, played a bit more than an hour then exited it to make lunch, after I got back, I opened Steam and launched Stonehearth…

Little did I know it wouldn’t run for some reasons, I get no errors, no messages, no bugsplats. Steam tries to launch it, then immediately cancels the action or exits the game(couldn’t figure out so far what the casue of the problem is).

I tried everything from restarting my PC to running it as an Admin, even surveyed the several Support discussions regarding the topic

Can someone help me? I really like the game and I have been watching its development for years, don’t really want to ask for a refund but if that is my last resort, I will do it.


#2

This problem is affecting many users, the thing is that it can also happen with other games (I’ve seen discussions on the Steam forums).

We haven’t been able to reproduce it on our end, so we’re not sure how can we help.

Does running the Stonehearth.exe while logged off from Steam help?

Does adding an exception for the Stonehearth.exe and for the crash_reporter.exe to your antivirus/firewall help? If you use windows defender, make sure they’re tagged as ‘Process’ in the exception, not as ‘File’.


#3

I have tried many supposedly working sulitons today.
Adding an exception for Stonehearth did not work(my Windows Firewall is not running either, os that can’t be the problem), so I decided to uninstall my antivirus(bitdefender) completely and see if that works, of course it did not.
Uniinstalling the game and then reinstalling the game does not help either, Steam tries to laucnh the game, it flashes for a tiny second and then immediately shuts down.
The only solution i found was reinstalling Steam itself and then reinstalling Stonhearth but after exiting the game, I still get the same problem.
The only reasonable explanation I can come up with is that Steam might create a file in the game’s folder after exiting it for the first time that prevents me from launching it…I haven’t found the file after searching for an hour but that must be the problem for sure.

Note: I haven’t tried launching Stonehearth offline since I did not know you could launch it without Steam, can you tell me how? Hopefully that would solve my problem.

Note2: As you mentioned, may users have experienced this problem lately so it must be something with the game files, can you look into the subject further please, I appreciate the help!


#4

Right click Stonehearth in your Steam library, click on Properties, Local Files tab, Browse local files button. It will open the folder where the Stonehearth.exe is.
Now log out of Steam, and double click the Stonehearth.exe from that folder.

It’s good information the fact that you can launch it once after reinstalling it, thanks for the details.

I found a new possible workaround looking in Google. In this page: Steam Games won’t launch!! [SOLVE] :: Help and Tips there are 2 workarounds suggested (it’s for other games, but I believe it’s the same issue - like I said, any Steam game can be affected).

One is logging out from Steam, then deleting (or renaming, to keep a backup of it) the GameOverlayRenderer64.dll file from the Steam folder (in default installations, that file would be located in C:\Program Files (x86)\Steam), and then restarting Steam so that the file is redownloaded. Not sure that this crash is caused by that, but if you can run the game without Steam then Steam is likely involved in the problem.

The other workaround is updating Rivatuner Statistics Server to version 7, but I don’t know which users have this (apparently it conflicts with that dll). There are many applications that can cause issues with the game. Even drivers from peripherals can cause conflicts.

EDIT: Forgot to ask! could you upload your stonehearth.log (it’s a text file) after the game crashes? (and a crash.zip if there’s any). They’re in the same folder than the Stonehearth.exe.


#5

So I launched Stonehearth while Steam was off, and got this file…

(the image is supposed to show the crash.dmp) Haven’t got this file while trying to launch the game from Steam, can’t open it as it is a dmp or at least I did not see it, might have got it earlier as well.
I don’t know about Rivatuner Statistics, I used it a while ago but it was not compatible with Windows 7 Home if I remember correctly, might give it a try as I have Windows 10 now. Btw, thank you for helping me!

Here is my log:

2018-11-09 10:24:47.646977 | server | 1 | app | Stonehearth Version 1.0.0.906 (x64)
2018-11-09 10:24:47.647936 | server | 1 | core.config | user id is 97e88269-ba48-485b-b9e9-2c47893fcb57
2018-11-09 10:24:47.647936 | server | 1 | core.config | session id is df0eeb0d-d6d5-4b6d-8983-1e2551c8431e
2018-11-09 10:24:47.648330 | server | 0 | core.system | Initializing crash reporter
2018-11-09 10:24:51.621070 | server | 1 | resources | Modules are verified pristine.
2018-11-09 10:24:51.715068 | server | 0 | app | Running Stonehearth server on port 62394
2018-11-09 10:24:51.715068 | client | 0 | client.core | Connecting to local server…
2018-11-09 10:24:51.716068 | server | 0 | physics.navgrid | subspace pathfinder is enabled
2018-11-09 10:24:51.716068 | client | 1 | game_engine | Initializing OpenGL
2018-11-09 10:24:51.741068 | server | 1 | mod radiant | lua controller lifetime tracking set to “nil”
2018-11-09 10:24:51.780067 | server | 0 | mod stonehearth.ai.service | enable_cpp_placeholders is on
2018-11-09 10:24:51.780067 | server | 0 | mod stonehearth.ai.service | enable_cpp_compound_action is on
2018-11-09 10:24:51.790067 | client | 1 | game_engine | Determining window placement
2018-11-09 10:24:51.790067 | client | 1 | game_engine | Selecting monitor at 960, 540
2018-11-09 10:24:51.790067 | client | 1 | game_engine | Creating OpenGL Window
2018-11-09 10:24:52.021070 | client | 1 | game_engine | GLFW Error (65544): Win32: Failed to set video mode on adapter \ (error: -2)
2018-11-09 10:24:52.056065 | client | 1 | game_engine | Error trying to create glfw window. (size:(1920, 1080) fullscreen:true)
2018-11-09 10:24:52.058064 | client | 1 | game_engine | Display device 0: Radeon RX 550 Series
2018-11-09 10:24:52.058064 | client | 1 | game_engine | Display device 1: Radeon RX 550 Series
2018-11-09 10:24:52.058064 | client | 1 | game_engine | Display device 2: Radeon RX 550 Series
2018-11-09 10:24:52.058064 | client | 1 | game_engine | Display device 3: Radeon RX 550 Series
2018-11-09 10:24:52.059064 | client | 1 | game_engine | Display device 4: Radeon RX 550 Series
2018-11-09 10:24:52.060065 | client | 0 | sysinfo | Memory Stats: Fatal Exception
2018-11-09 10:24:52.060065 | client | 0 | sysinfo | Total System Memory: 7.983 GB (8571179008 bytes)
2018-11-09 10:24:52.060065 | client | 0 | sysinfo | Current Memory Usage: 142.457 MB (149377024 bytes)
2018-11-09 10:24:52.060065 | client | 0 | sysinfo | Total Address Space: 128.000 TB (140737488224256 bytes)
2018-11-09 10:24:52.060065 | client | 0 | sysinfo | Available Address Space: 127.996 TB (140732642443264 bytes)
2018-11-09 10:24:52.060065 | client | 0 | sysinfo | Used Address Space: 4.513 GB (4845780992 bytes)


#6

Don’t install Rivatuner if you don’t have it, as it has nothing to do with the game.

According to the log, the game couldn’t initialize the graphics. Do you have the latest drivers from your manufacturer’s website (AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops)?

I guess the crash.dmp will also point to that failure. You might try to run in windowed mode and see if there’s any difference:

  • In the same folder than the stonehearth.log there’s the user_settings.json. Open it wil a text editor, and change "enable_fullscreen" : true, to "enable_fullscreen" : false,. Save the changes and restart the game.

#7

I have the latest driver for my Radeon RX 550 Gb VGA and for my CPU as well(AMD).
I opened the .json file and looked up the enable_fullscree title, it was already set to enable_fullscreen : false
Tried to change it to true, didn’t hope for much, but it did not work.


#8

That’s strange. In your log it says it was set to true :thinking:
Just to confirm, did you edit the user_settings.json and not the stonehearth.json, right?

Could you upload that crash.dmp from before? It might have some info. I wonder why it’s crashing on the graphics but didn’t generate a dmp when you were logged to Steam.


#9

Oh man, I am so clumsy sometimes, edited Stonehearth.json accidentally, the game launched after editing the right file in windowed mode, gonna post the crash.dmp later (have to go for now) for further users, we might be able to figure out a better solution to this. Tho I don’t mind the windowed mode that much…
Thank you for your effort and time :smiley: