It's stuck on loading screen

So basically every time I try to play stonehearth. I can play the game, but when I save and exit and come back, the game just doesn’t do anything after the loading bar is complete. It just sits there. I’ve tried uninstalling and reinstalling. I’ve also tried deleting all stonehearth files. Please help.

Welcome to the forum, @Mike1311 :slight_smile:

Could you upload your stonehearth.log file? It should be inside the folder where you have installed Stonehearth (typically C:\Program Files (x86)\Steam\steamapps\common\Stonehearth ).

If it gets stuck with the full bar indefinitely, there must be an issue when you load.

It can take a little bit to actually start the game after the bar is full, but not minutes.

1 Like

Thank you for taking the time to reply. I am embarrassed to ask this. But how do I upload a file to this? I tried copying and pasting but it doesn’t work.

You can drag and drop it into the reply or use the arrow button on the toolbar and select the file from your computer:

stonehearth.log (36.8 KB)
Is this the correct file?


Yes, it is. Thanks.

1 Like

I think I’ve uncovered the issue. What happens if you press F5 when it gets stuck for too long? I think that will make it so it goes to the game UI. There was a bug where the loading would inadvertently wait forever, but pressing F5 (which is UI refresh) might fix it.


Thank you both. I can finally play again. yayyyyyyyyyy.

1 Like

sorry about that! Glad the work around is working for you