Items go missing while building

So, I’ve tried to build this house several times on the save attached. I think I’ve attached it correctly… However, each time I build the house certain items go missing… It differs each time I reload the game.

Here’s what I did:

  • Planned the house and started building.
  • I have all the required items for doors, windows and storage crates.
  • When the hearthlings start putting items in the house it’ll say I have a door missing, sometimes windows and several crates.
  • It’ll require me to build more items to replace the ones that have disappeared.
  • After this has happened the ‘place an item’ tab shows items as available but I cannot find them anywhere in the town. The place an item tab also goes slow and unresponsive, and I cannot place down the items it claims I have.

Sorry if this isn’t very clear, it’s a bit of a weird bug and it hasn’t shown any errors that I can attach. Items just seem to randomly disappear!

Hope this is okay,

Stonehearth Save.7z (3.2 MB)

1 Like

The only mods I have by the way are - Better Storage and Town Monitor :slight_smile:

If you build a template with excellent or fine but he doesn’t create it by chance, it will be waiting for an upgraded item forever. You’re sure that’s not it ?

I don’t think so. I have the necessary items at the start of the build. I start building and two or three disappear and say I need to build more to complete the build

Can you upload the save and then reload ?

I’ve just tried this and it didn’t work.
Before items need to be placed : 5/5 doors available, 15/15 windows available, and 9/7 large crates available.
While placing items: 0/1 doors available, 0/2 windows available and 0/1 large crates available.
I’ve waited for a day in case someone was carrying them or going to put them in but nothing ever happens. Sometimes its other items that disappear too.

I’ve tried restarting the save several times, and going back by a few days to no avail. They disappear and I’m left with items in the ‘place item’ tab that cannot be placed and don’t seem to be visible in the town.

Thanks for the save and the details! We’ll take a look.

1 Like

This is an old bug… It has bothered all of us. I had this wall with a ton of lamps in it. It was quite fascinating to see them poof one by one as new had gotten placed.