Issues with Alpha 9

#5

sorry if i misinterpreted this but, your not sure if you are? or was that just me being a slight grammer nazzi

#6

I have only used the Humble Bundle client…

#7

ok… if you don’t mind, please grab your steam key (from your Humble Bundle account) and launch the game via the steam client… let us know if you have better results… :+1:

#8

Okay thank you. Will do!

#9

Umm… could you help me out with that actually? It shows me the key I need to use but doesn’t show me an option to use it… Sorry I’ve never done anything with humble bundle before :confused:

1 Like
#10

no worries… see if this helps! :smiley: :+1:

lifted from the FAQ:

  1. Steam keys? How do they work?

When you get to your Humble Bundle download page, you should see 3 ways of getting the game: by downloading a zip file, by downloading an installer, and by getting a steam key. This way, you can have the game both on steam and on your local hard drive, if you want! To use your steam key, grab it from your HB download page and:

  • Open Steam.
  • From the menu, select “Games” -> “Activate a Product on Steam…”
  • Click “NEXT” until it asks you to enter a Product Code.
  • Copy/paste the Product Code / Key into the text box and click “NEXT”.
  • Steam will confirm the product code by indicating that you have access to “Steam Sub 30994” (the Stonehearth Alpha).
2 Likes
#11

Yep @SteveAdamo … It’s happening with the Steam one too…

#12

Haven’t been able to play for more than 6 minutes so far

#13

are you playing the 64-bit client?

1 Like
#14

Yes I am using 64-bit

#15

ok, give the 32bit client a try and let us know how that goes…

also, go ahead and list your system specs as well (OS, processor, graphics card)… thanks!

1 Like
#16

Nothing has changed with the 32-bit, it does the same exact thing @SteveAdamo

System Specs:

Processor- AMD A4-5300 APU with Radeon™ HD Graphics 3.40 GHz

RAM- 4.00 GB

System type- 64-bit Operating System, x64-based processor

#17

Can you please attach your stonehearth.log file? That would help us diagnose the problem.

1 Like
#18

2015-Mar-25 20:51:45.311477 | server | 1 | app | Stonehearth Version 0.1.0.256 (x64)
2015-Mar-25 20:51:45.327102 | server | 1 | core.config | user id is 5a15ae36-d308-11e4-9249-50465da2e549
2015-Mar-25 20:51:45.327102 | server | 1 | core.config | session id is 6be56594-d36b-11e4-a701-50465da2e549
2015-Mar-25 20:51:45.327102 | server | 1 | core.timer | QPC count: 6216965392580, frequency: 3419748
2015-Mar-25 20:51:45.327102 | server | 1 | core.timer | QPC count: 6216965392704, frequency: 3419748
2015-Mar-25 20:51:45.327102 | server | 0 | core.system | Initializing crash reporter
2015-Mar-25 20:51:45.842730 | server | 0 | lua.code | lua jit disabled in 64-bit builds. set force_lua_jit to override
2015-Mar-25 20:51:45.842730 | server | 0 | lua.data | lua jit is disabled
2015-Mar-25 20:51:46.920854 | server | 1 | resources | Modules are verified pristine.
2015-Mar-25 20:51:46.936480 | server | 1 | app | Running Stonehearth server on port 39025
2015-Mar-25 20:51:46.952104 | server | 1 | lua.code | could not find path for lua script “lualibs/unclasslib.lua”.
2015-Mar-25 20:51:46.967729 | server | 1 | lua.code | could not find path for lua script “modules/common.lua”.
2015-Mar-25 20:51:46.967729 | server | 1 | lua.code | could not find path for lua script “modules/timer.lua”.
2015-Mar-25 20:51:46.967729 | server | 1 | lua.code | could not find path for lua script “stonehearth/stonehearth/lib/loot_table/loot_table.lua”.
2015-Mar-25 20:51:46.983356 | server | 0 | mod stonehearth | greedy task scheduling enabled
2015-Mar-25 20:51:47.014605 | server | 1 | lua.code | could not find path for lua script “stonehearth/radiant/modules/filtered_trace.lua”.
2015-Mar-25 20:51:47.030231 | server | 1 | lua.code | could not find path for lua script “stonehearth/stonehearth/lib/entity_forms/entity_forms_lib.lua”.
2015-Mar-25 20:51:47.248982 | client | 1 | horde.general | Initializing GL2 backend using OpenGL driver ‘4.2.12422 Compatibility Profile Context 13.152.1.1000’ by ‘ATI Technologies Inc.’ on 'AMD Radeon HD 6450’
2015-Mar-25 20:51:47.811482 | client | 1 | browser | cef started.
2015-Mar-25 20:51:47.811482 | client | 2 | browser | Navigate called without an existing browser!
2015-Mar-25 20:51:47.811482 | thread6032 | 2 | browser | Doing a buffered navigation…
2015-Mar-25 20:51:47.827106 | server | 2 | network | server allocating new send buffer (total: 0)
2015-Mar-25 20:51:47.889606 | client | 1 | lua.code | could not find path for lua script “lualibs/unclasslib.lua”.
2015-Mar-25 20:51:47.889606 | client | 1 | lua.code | could not find path for lua script “modules/common.lua”.
2015-Mar-25 20:51:47.889606 | client | 1 | lua.code | could not find path for lua script “modules/timer.lua”.
2015-Mar-25 20:51:47.905233 | client | 2 | network | client allocating new send buffer (total: 0)
2015-Mar-25 20:51:47.936483 | client | 1 | client.core | user feedback is on
2015-Mar-25 20:51:48.252846 | server | 1 | simulation.remote_client | started buffering client updates. (seq:10 ack:0)
2015-Mar-25 20:51:48.440347 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:10 ack:10)
2015-Mar-25 20:51:51.184896 | server | 1 | simulation.remote_client | started buffering client updates. (seq:66 ack:56)
2015-Mar-25 20:51:51.372393 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:66 ack:66)
2015-Mar-25 20:52:01.941099 | client | 1 | client.core | reporting sysinfo
2015-Mar-25 20:55:02.382201 | client | 1 | renderer.render_info | could not load qubicle file: invalid file path ‘’.
2015-Mar-25 20:55:15.073920 | client | 1 | renderer.render_info | could not load qubicle file: invalid file path ‘’.
2015-Mar-25 20:55:21.654296 | client | 1 | renderer.render_info | could not load qubicle file: invalid file path ‘’.
2015-Mar-25 20:55:23.847116 | client | 1 | lua.code | unrecognized object type ‘boxed’ in json_to_lua!
2015-Mar-25 20:55:23.847116 | client | 1 | lua.code | unrecognized object type ‘boxed’ in json_to_lua!
2015-Mar-25 20:55:41.812506 | server | 1 | simulation.remote_client | started buffering client updates. (seq:3021 ack:3011)
2015-Mar-25 20:55:41.994939 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:3021 ack:3019)
2015-Mar-25 20:55:42.307438 | server | 1 | simulation.remote_client | started buffering client updates. (seq:3029 ack:3019)
2015-Mar-25 20:55:42.419570 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:3029 ack:3021)
2015-Mar-25 20:55:42.470958 | server | 1 | simulation.remote_client | started buffering client updates. (seq:3032 ack:3021)
2015-Mar-25 20:55:42.652657 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:3032 ack:3029)
2015-Mar-25 20:56:37.520500 | server | 1 | simulation.remote_client | started buffering client updates. (seq:3966 ack:3956)

#19

That’s the stonehearth.log right? Lemme know what you think the problem is!!
Please and thank you @Tom

#20

Did that help? Think you know what the deal is? I still can’t figure this out… And I really wanna start playing for reals :confused: @Tom

#21

There was a memory leak in Alpha 9 that has now been fixed, has your Stonehearth updated to build 2395 yet? You’ll need to start a new game as the game saves won’t be compatible. You need to be running the 64 bit version btw.

1 Like
#22

Thanks so much man! I’ll give that a shot! How exactly would I go about updating to the 2395 build?

#23

in your steam library,

  • right click stonehearth
  • select properties
  • click on the betas tab
  • select latest, no key necessary
  • enjoy

if you dont have it on steam i can tell you how to get it

#24

Let us know if this works for you! There are some great tutorials for installing this game.

1 Like