Infinite UI Errors When placing blocks ontop each other in building editor

Twice now I have been able to place blocks on top each other inside the building editor. Unfortunately the game crashes so quickly it is so hard to get a good image of it so I’ll try my best to describe it.

First Time:

I was trying to trick the game into building a wall in between two rooms, so I erased a section of floor 1 block wide in order to force both rooms to place a wall in between them. When the editor did this, I got infinite UI errors adding up to the counter.

Second Time:
While I was designing a structure, I accidentally dragged a road into the floor of the structure (and the wall). When I finished placing it into the structure I tried to erase the road but it wouldnt take. So I tried to delete the structure and start over. When I did this, it could not delete the structure design and would give me infinite UI errors.

If I come to this error again, I’ll try to screenshot it very fast. I easily get to 5000 errors so fast I cant do anything.


Welcome to the forum, @Palidin :smile:

Unfortunately, I think that building walls to make separate rooms is still buggy at the moment (paging @Atralane, do you know what is the current workaround to build this?).

The piling errors should be in your log too. You can upload your stonehearth.log file (it’s inside the folder where you have Stonehearth installed) to an external site and paste the link here. Or you can wander around the forum, write some posts, like some posts, and after a time you will be able to upload that file directly to the Discourse.

Make sure that the log file is the one right after you get the errors.

1 Like

Interior walls are still pretty limited and tricky at the moment. The best option right now is to build walls using the Slabs (free-design) tool, but I believe it has trouble if there’s a ceiling above (for example, the ground floor of a two-story structure). The last time I tried, the Hearthlings couldn’t complete the top two or three rows of voxels since they were bumping their heads against the ceiling. Granted, this was a few releases back, but I don’t believe this would have changed yet.

As for doors and windows, I don’t know if it’s possible to put them inside a building. If so, it’s through glitching the construction system and might cause some issues down the road for that game. This post by @Kythandra suggests that it should be possible:

Placing Doors and Windows

If I’m seeing it correctly, Haru-Jo (@Kythandra’s recent excellent project) utilizes this placement technique (or are the windows in regular walls made of singular colors?). Might need some testing to see how well it works for different situations.


This was using the undo button or with the eraser tool?

It doesnt look like my log file still has the errors in it. But I did try to reproduce the issue and didn’t have any errors.

Yes I first Built a floor. Erased a 1 block wide section of said floor. Then I placed a wall down, that way the floors would build a wall in between them an create a room! The issue is, each side of the floor builds its own wall, is what I suspected caused the errors, today I got not a single one.

So I actually tried building it, with a door in one of the walls. As I suspected, they completed the building with no problem and no errors. Of course I only placed a door on only one of the walls, so the hearthlings could still not get through the wall, due to it’s double thickness.

I’m guessing the new build prevents errors when items are stacked ontop of each other.

I also tried the error with the floor and couldn’t reproduce it, I posted the two issues together because I figured they were related to stacking blocks on top of each other in the editor. It looks like the editor does not care when you do that in the current build.

1 Like