Incremental building orders for ladders not always carried out

Summary: I was digging out a mine in my latest playthrough of R210. Of course, the citizens try to make it so that they can path their way out as long as possible, which is really nice; however, this also means that you have to wait until they’re almost fully done to construct a ladder all the way down. At first, I waited for this, but when I tried to dig it out further, I decided to try to add a little bit extra to the bottom of the ladder whenever they dug an extra layer out. This worked fine for the first couple times, but then when I built the last bit (30:30), the citizens did not carry out this last section of the ladder. It was still not built by 59:40, which was after a bit where the citizens had nothing else to do and were just idling. At that point, I designated another ladder to be built anew all the way down, which the citizens promptly did, so it was not a matter of not being able to reach down that far from the top. (After that, at 1:00:35, the rest of the first ladder was also built, but from the bottom.)

Steps to reproduce: Difficult to say if it’s consistent, but I’d just do what I did: dig a mine shaft down and continually extend the ladder into it as the workers dig further.


Versions and mods:
No mods, latest release version in Steam at the time of writing, version 0.1.0 (release 210) according to the title screen.

System information:
DxDiag 2015-03-15.txt (66.7 KB)

1 Like