[Help Request] Yet another wall I hit. Item Scaling

Hello everyone, I apologize for all the posts I’ve made since I joined yesterday and thank you for your patience.

So i want to give an off hand weapon to my cleric for some basic defense. This case would be a staff like in this statuette.

Problem is, that after creating it (it is 28 cubes long, same as the bow) it looks tiny in my cleric’s hand!!
Here is a picture for reference.

Does the game apply a different render to off-hand items?
Here are my files in case someone wants to check them out
cleric_staff.zip (7.8 KB)

Have you tried removing the render_info section in your staff’s .json and seeing if that changes anything?

Specifically, try removing this:

"render_info": {
				"scale": 1.5

I did. When I first created it, it had no scaling info, I tried to add that to see if I could make it 1.5x bigger.

Right now it just looks like a tiny wand instead of a staff hahaha

I didn’t change anything, but I imported the model into VoxelShop and exported it using the VoxelShop settings for Stonehearth, then I tested it on a cleric and it looked fine to me. Here’s a picture and here’s the .qb file for you!

cleric_staff.qb (615.8 KB)

1 Like

Omg that’s awesome! I used StoneVox. Thank you sooo much!

1 Like

Not a problem! I 100% recommend the switch to VoxelShop, it supports multiple matrices and has a lot of beneficial features that I really wish I had when I first started modding - like you can select all voxels of a specific colour. Not only that but it’s less buggy than StoneVox (still not 100% bug free but very good for a free editor!).

1 Like

I didn’t use VoxShop because the outfit, for example is outside the grid box.
Like so

also when I click on the Stoneheath export link, it takes me straight to the main github page for the software, so I don’t know what are the settings for exporting.

That is one of the annoyances with VoxelShop, you have to move the models back into the middle of the gridbox (it doesn’t need to be centered, just inside the grid. If you select all voxels, then click the XZ View and use the arrow keys you can easily move it to the middle with little effort however.

In terms of how you export it, simply select options 2 and 5. Also ensure that the grid box is 31 41 31 (you can change size by pressing the arrow directly under the grid box.

1 Like

Alright, thank you for all your help!

Hmmm, still appears small in mine. did you changed anything else?

That’s strange, are you using the model I sent you? All I did was import it into VoxelShop, then export it and load it in to the game.

yup, although I ppened it and that’s the equipped version, not the normal cleric_staff

this is using the model you sent me.

Okay, I have it working scaled fine in my game, you will have to work out the positioning yourself - I’m headed to bed. If you’re still struggling with it by tomorrow I can help you with it though - essentially you’ll need to fiddle around with the ‘model_origin’ info.

cleric_staff.zip (8.0 KB)

This is exactly what I have working in my game - so it 100% should work in yours. Good luck, my friend.

1 Like

Thank you for all the help, your goblin heads look awesome by the way

1 Like

My pleasure, asking for help is a great way to learn! Ahah, thank you!