Hearthling refuse to place certain items

Title: Hearthlings refuse to place certain items

Summary: Hearthings wont place a Forge, Anvil, Or bed anywhere near my blacksmiths house,

Steps to reproduce:

  1. Make a house for your blacksmith
  2. Try to place a forge, anvil, or bed
  3. wait for them to let you down

Expected Results: Your hearthlings wont let you down and will place the items

Actual Results: They wont place anything at all near it

Notes: They place other items just find, they still build buildings. I tried restarting, making new anvils and forges and used a console command to destroy the house and rebuild it :confused:


Version Number and Mods in use: Release-491 (x64) Alpha 13

Did you try to pause the game for a few seconds ?

Yes I have, still nothing. Also noticed that the little sparkles are gone on the items, so im remaking them now to see if that helps

May you upload your save ?
If you don’t know how to, please read this message :slightly_smiling:

Was the structure completely built before you tried to place the items down? If not, they get added to the blueprint of the building, which for me tended to cause issues in the past.


1452316064367.zip (6.1 MB)
Sorry for the late reply, was out of the house, but here is the save, and it wasnt added to the blueprints because i didnt have a blacksmith at the time i built it

Anyone able to replicate this bug? and maybe try and fix it? My save is pretty much at a stand still war between zombies, many goblins and hordes of skeletons at the moment because i cant make anything better than a stone maul XD

Edit: @jomaxro or @8BitCrab You two seem like super smart people. Mind helping me out a bit? I really want to continue my game but I cant because there’s only so far I can go without a blacksmith

@demonsage, when I download your savefile it says the file is not valid, and I can’t extract it.

From the link you’ve provided, the .zip weights 6.1 MB, is that correct?
Did you wait until the file finished loading before clicking to post?

Maybe there was a problem when you uploaded it to Discourse. :sweat:

@Atralane was thinking about something else : when you’re building a house, you can add stuff around or inside the house and these items will be part of the house. However, if you wait for the end, the items will be placed apart from the house. And we know that there’s still a problem with the houses.

So if you added the items while the house was under construction, it may have bugged.
But check out your save, because @Relyss can’t download it :wink:


A post was merged into an existing topic: Attempt to index field ‘fabricator’ (a nil value) - in function ‘_trace_project_region’

That’s a building error. Now it is confirm that your items are not placed because of your house.
Hurray @Relyss ! :grin:

1 Like

Yayyy. So does that mean we have a solution XD i was just attacked by like 6 undead and my one footman needs new gear before he gets stomped on. He can take like 4 at once but anything more than that and hes screwed

EDIT: So whenever I try to place the forge it says its added to the building and idk why because the building is finished

EDIT Pt2: Just got this error

release-491 (x64)
No matching overload found, candidates: void __add(lua_State*,Point3 const&,Point3 const&)
stack traceback:
radiant/modules/events.luac:84: in function <radiant/modules/events.luac:81>
[C]: ?
[C]: ?
…th/services/server/build/scaffolding_builder_1d.luac:136: in function ‘_cover_project_region’
…th/services/server/build/scaffolding_builder_1d.luac:100: in function ‘_update_scaffolding_size’
…th/services/server/build/scaffolding_builder_1d.luac:54: in function ‘set_teardown’
…th/services/server/build/scaffolding_builder_2d.luac:41: in function ‘set_teardown’
…arth/components/fabricator/fabricator_component.luac:231: in function ‘_start_project’
…arth/components/fabricator/fabricator_component.luac:139: in function ‘_updates_state’
…arth/components/fabricator/fabricator_component.luac:135: in function 'obj’
radiant/modules/events.luac:44: in function 'instance’
radiant/modules/events.luac:98: in function <radiant/modules/events.luac:96>
[C]: in function 'xpcall’
radiant/modules/events.luac:96: in function 'trigger’
radiant/modules/events.luac:121: in function '_trigger_gameloop’
radiant/modules/events.luac:150: in function '_update’
radiant/server.luac:19: in function <radiant/server.luac:17>

EDIT Pt3: So I tried placing the anvil and forge anywhere else, they’ll place down without a problem i hope that helps XD

Can someone close this thread please? I fixed it, all I had to do was remove the overhang and rebuild it after for some reason ^-^ Guess it was in the way

Did you really tear up your entire house ? If so, you’re lucky because normally it bugs and you cannot.
So it was definitely a construction problem :slightly_smiling:

yea, had to use the destroy command and then i rebuilt it piece by piece until the only thing left unbuilt was the overhang, then i placed the stuff, than built the overhang XD

The destroy command may not work and usually you have to use the debug tool. Glad you did it without :smile:

Not going to close the thread just yet, as there are some engine errors here, but glad to hear that you got it working!


Alright ^-^ If I get more errors ill totally post them in the proper place