Hearth(campfire) can not be moved


exe file ver =

I firstly realized the hearth can not be moved when I try to move hearth to new building in my 4th tier3 town.
I loaded previous 3 towns which already had been departed, and they have all same symptoms.

I tried to use “teleport” console command, but result was similar to this. Hearthlings sitting where the campfire used to be

After then, I tried to use debugmod. I used item stamp to copy the hearth, and 'destroy’ed original one, and placed copied one. Then it looks like fine awhile. People now normally find new place of campfire. But entity id is changed. Is this fine to change entity id? At a my glance, only main difference except object entity ids of original one and copied one is the attribute of “move” command button object, “enabled=false” and “enabled=true”.

I don’t know when it changes into “false”, yet.


I’ve had this experience too. Also with the Hearth of Makers. The box command mod gave me a workaround.

Do you have a save with this bug in it so I could take a closer look? Also, is there anything deployed on top of the fireplace?

I’m glad to see an response from developer.
Unfortunately, I deleted old savings. But I created one for quick test.
I knew it when the button changes into disabled. It’s disabled when beating titan.

Here is attachment,
before.zip (5.1 MB)
after.zip (4.9 MB)
one is just before beating titan (hearth can be moved) - you can beat it by just using arbelest.
another is some days after beating titan (hearth can not be moved)

If hearth is placed on a building blocks before glitch occur, after beating titan, hearth can be placed once more by destroying the building beneath it. But placed hearth may still have disabled button.

same exact problem