Having immediate lag spikes as soon as I create my settlement

Welcome to the forum, @Ferimroth :smile:

Were you able to play Alpha 13 without lags on your previous computer?

I can only think of maybe some antivirus or application that is interferring with the game, perhaps :confused:

Yeah I have been able to play fine on the old computer as its still being used upstairs but as its an older computer it suffers a little on performance. I will have a look at at my antivirus. Just sad not being able to play it on my new one as thats the one i use 99% of the time :frowning:

It has this issue both playing via steam and the humble bundle link to the game.

I took a brief screen capture of my issue. I am able to move the camera fine during spikes.

1 Like

Thank you very much for the video, I’m sure @Albert or any other of the devs can get a better idea of the spikes this way :smile:

In the meantime, can you also check that your video card drivers are updated (from your manufacturer’s website)? It can’t hurt.

1 Like

I’ve checked my drivers and they are all good. Any ideas?


Nope, sadly no more ideas beside that there could be something like an antivirus or other application interferring with the game, which might be completely wrong, it might be something else which is causing the spikes.

You can try searching for any of these applications and libraries on your computer, but they are mostly causing crashes so I doubt it’s one of them, besides your computer is pretty new so it shouldn’t have many things installed, I guess…

Maybe try running on compatibility mode (Windows 8 option)?

Hey there, im having the same issue. Just built a Custom PC, its a nice Gaming rig with room for expansion.
Intel® Core™ i5-6600K CPU @ 3.50GHz (4 CPUs), ~3.5GHz
16 gigs ram
Windows 10
Tried compatibility mode in 7/8 with no help.
also seems to have a large Idle spike when it when it happens, and everything else keeps running. I had a 5 yr old hp laptop that ran it “steady”, with some obvious performace issues on its end, but it stil lwas able to get to a 20ish person city before it totally lost it. and never had this stuttering on the old comp. otherwise word for word same as what happening to Ferimroth, exactly same as video, no setting change anything. same intervals of lag.

If anyone else is having this on a good gaming comp post plz! must stonehearth in real graphics

I’ve encountered this problem too; being reasonably built up and after spat with some goblins and losing half my villagers it seems their processes (and possibly the goblins too) are in an infinite loop instead of being ended on death (as previously mentioned, the more villagers you have the more lag you have which is why 20 villagers are recommended tops.) I also ponder how the processes are being coded having experienced this myself as a developer on a similar game and finding spreading the processes in different threads helped a lot.

(said game was dumped as manager was a )

1 Like

Just in case it’s helpful, I have identical specs to your computer (slightly different processor, AMD A6, same RAM, same video card) and I haven’t experienced anything like this, so it must be a driver/software issue.

1 Like

Im having this issue too. It seems to get worse as the game goes on. Here is my system:
Asus ROG Z170 Maximus VIII Hero
EVGA GTX Titan X Superclocked
Kingston HyperX Predator 12GB DDR4 3000mhz
Samsung 850 Pro 1tb

As you can probably tell, lag isn’t something I get a lot, so I would like to get it sorted so i can get back to playing. I noticed that the game got up to over 6GB ram usage, so I restarted the game which fixed the performance a bit but it quickly went back to being slow again, which my admittedly extremely meagre coding knowledge would attribute to a memory leak. I can’t imagine 6GB is the sort of ram usage that the game is supposed to be at.

1 Like

Still suffering from this issue have not been able to find any kind of a solution. Gutted that i bought multiple copies of this game and racked up nearly 200 hours of gameplay before this and its now impossible to play :frowning:

1 Like

@Ferimroth, @Nazgren, @Velvet, what version of the game have you been experiencing this on? Alpha 13 has some major memory leaks that @Albert has been working really hard to deal with. Some have been fixed in the current Alpha 14 develop builds, but he is still working on at least one.

Version 0.13.0 is what is available for direct download from Steam. How long has alpha 14 been available? As explained I’ve had this game for two days - how do I get the latest version? Also just noticed 13 is still advertised as latest version on Stonehearth website…

@jomaxro I’m at work so can’t really see what version I’m running but it’s been happening with every update that happens with no changes in the behaviour of the game. The video i posted a month ago is what happens every time I put the settlement flag down on both stable and unstable versions of the game. Tia

I’m on the beta patch, I had the same issues in 13, but that would crash a lot sooner then 14 is, so it’s getting better! I must just be suffering from whichever one Albert is still fixing. I’ve waited since the start of the Kickstarter, I can wait a bit more! Just gives me more time to learn Qubicle!

1 Like

Right click Stonehearth in steam, click the Betas tab, click the drop down box and click “latest- Latest build. Minimally tested.” There will be a patch ~50-80mb and you will have alpha 14!

1 Like

As @Nazgren mentioned, there are two “branches” of the game on Steam. The primary branch (un-named), which is receives a major release about every 2 months (sometimes quicker, sometimes slower), and a few patch releases. This branch is considered more “stable” as the builds have been tested for a good length of time before release. The secondary branch is called Latest, and can be accessed as explained by Nazgren. This branch is updated more frequently, but also tends to contain more bugs (ie. less stable). For more details on the branches (and step by step instruction for accessing the Latest branch, you can check out this page on the Stonehearth website: http://stonehearth.net/development.

Good to know. Your original post was made just before the devs went on their holiday vacations, so it is quite possible this slipped through the cracks. Let me repage @albert and @not_owen_wilson to make sure they see this. Also going to ping @Ponder as he has been doing a good deal of work on performance related improvements as well.

I worked out how to update my version; currently on Alpha 14. I’m still getting the lag, but think I’ve worked out why: if I place any more than 20 orders at once per profession it slows the game right down.

I have same problem but I don’t now why.
My system :
AMD Ryzen 7 2700X
Manli geforce gtx 1080
8gb corsair vegance lpx
128gb M.2 ssd + 1tb Seagate baracuda

I have got the game also like 1-2 year/s ago. And never had a problem with the game. On my old pc I only had 15 Fps but that was a problem from my old pc. Yesterday I went in the game and it start to lag but I had like 80 - 120 Fps. I can’t see a problem with my Hardware and my card drivers are at the latest version. I play with high graphics and 64 bit. But I also tried low graphics or 32bit but it don’t change something. My game is on the newest version.