Graphical Crash when too many items queued for a crafter

no_longer_applicable

#1

Summary:
When queuing items for a crafter (carpenter or weaver at this point) to create the HTML layer will sometimes crash when the number of items to make exceeds the space to show them on the right of the crafting menu.

Steps to reproduce:

  1. promote a worker to a weaver
  2. queue more than four items for the weaver to make
    3)HTML layer will crash

Expected Results:
Items will continue into an overflow list with arrows to move throughout the menu

Actual Results:
The HTML layer crashes allowing the game to keep running but not allowing anything in a menu to be selected, including the Esc menu to save or exit the game

Notes:
I could not reproduce this with the carpenter, and it may take more than four items to have the interface crash, as it was rather abrupt I did not think to count the item queued to be made (I think it was five and I clicked a sixth), I also did not grab the error text that popped up before it disappeared and I was unable to interact with any of the GUI to bring it up again.

Attachments:
[None]

Versions and Mods:
R130 No Mods

System Information:
Windows 8.1 (64-bit)
Lenovo Y510P
Intel Core i7-4700MQ (2.4 GHz)
nVidia GeForce GT 755M
8GB RAM


[Dup] Crafting window stopped responding when trying to make 4 chairs
#2

I had this happen as well, with the exact same results.

I can confirm that it happens with the carpenter. It was triggered by selecting the carpenter’s bench and building multiple windows, doors, wall lamps, and garden lamps. Not sure if I had other items queued up, but could have had a tool in there as well. I haven’t been able to reproduce it though.


#3

We’re trying to reproduce this! Can you be very specific and/or show the error message you get?


#4

I would love to, unfortunately I have not been able to get it to happen again (I have tried a couple times, not too hard as of yet). I will be able to play the game some later this week and will try and recreate this and grab some screen shots at that time.


#5

Hi,
When i selected the simple wooden chairs and chose to make 4 of them, up popped a bunch of error windows and then the crafting window was dead (i.e. could not “X” close it, could not select any other options in the game) and had to force quit the game.

Just thought I’d let you know if somebody hadn’t already.


#6

hey there @City_Builder … the next time you get the popup, try and capture the image and add it here…

thanks!


#7

See this thread, and please update if you can recreate it!


#8

Mmm… Let’s assume it’s the same bug, giving the similarities…


#9

Thanks! Any screens you have of the error would be super useful to us.


#10

I also had this bug. I had just created my weaver’s crafting table. It was the first time I had her make items. I told her to “keep 6 threads at all times” then added “keep two skins/leather at all times” then went to add another item and that’s when the menu stopped responding. I could click on things in the background, a fox, a person, a post, etc. they would highlight yellow, but I could not see the text for the item and it would not close the menu. That menu stayed open, with the queue of work missing, and I could not use Escape or any other way to get out of it. I minimized the window, and that crashed the game. I lost my game, since I had not saved. If it happens again I’ll get screenshots.

In that same game, before that major issue (above) I had a building not be built. I’m not sure why so I deleted the building and built on the other side of my supplies. That worked out.


#11

I had the pretty much the exact same scenario as @Aurrie. The only difference was i maintained 2 Cloth at all times as well as 6 threads.

Only broke once though, the other times it worked fine.


#12

What luck!

I haven’t played since last Tuesday or Wednesday and had a glitch similar to when I first posted on this thread.
I’m using the current version, and had the UI crash after queuing two farmer’s hoes and tne weaver’s spindle. Crash occurred immediately after clicking on the Craft! button. A second error box popped up when I tried closing the crafting window, and then the crafting UI wouldn’t respond to anything. Here are some pics:

Before clicking the “x”

After I tried closing the crafting window

N.B. I’d have made a new thread for this but I’m convinced it’s the same problem. Could the bug not be related to queuing too many items? Hope the pics help!