Glitched Object movements

Items glitching when asked to move their locations

I have a Tombstone and my Potter’s Kiln which refuse to be moved.

Steps to reproduce:

  1. Worker died during IDLE AI issue,(which has now been fixed) unknown how to produce, however Tombstone can not be moved.
  2. Attempted to move Kiln location after trying to move stuck Tombstone, town randomly all went IDLE, did not move.
  3. Closed the game out, opened it back up, no characters are attempting to move Kiln. Attempted to move Kiln a second time, however it did not move. Ghosted image of Kiln location is doubled (flashing between the two times).

Expected Results:
To give me the option to cancel the move and try again, or have a character move the item.

Actual Results:
Movement never happened, items are “stuck”.


photo stonehearthbug1-4.png

Versions and Mods:
release-483 (x64)
Updated to:
release-489 (x64)

System Information:
Runs game on Windows 8.1 Compatibility Mode
Intel Core i7-4770 @3.4GHz
NVidia GeForce GTX750
RAM 16.0GB
Windows 10 Pro 64-bit

It’s not obvious, but I think this is what’s going on:

  1. In order to move a tombstone, you have to have access to the front or back (and that ladder is on the side).
  2. In order to place a kiln, the opening must be unblocked. It’s hard to tell from the screenshot, but the opening might be obstructed.
1 Like

Ok, I’ll try both and see what happens.

Ok, after having to make multiple ladders until I found one they would agree with (the Tombstone is on a bush – not flat surface) that was fixed. Then, I tried the Kiln again, and it worked. Thank you!

1 Like

Hey there @Nikia, glad you were able to figure it out. Just wanted to say welcome to the Discourse, and I hope to see you around! :smile:

1 Like