Game won't start on new computer (Steam)

Downloaded my game on a second computer (Laptop) and my game won’t start. After clicking “play” it will open the usual “preparing to launch Stonehearth…” window, while the window is open the game says it is running, then the window will close and the game will stop running altogether and the play button will appear again as if I didn’t press it to begin with. Stonehearth does not appear as a background operation, the game simply closes before it starts.

I have tried:
Shutting down laptop
Restarting laptop
Checking drivers
validating files
clearing appcache
turning off active virus scanning
turning off firewall
Starting the game through the application in my file folder instead of steam

After all this there has not been the slightest difference. I have had the game since 2017 and never once encountered this problem.

Edit: I have also tried compatibility mode
according to task manager, Stonehearth does not even open as a task.

Have you tried plugging in a gamecontroller
Is it touchscreen

I have not, and no, it is not a touch screen.