Game crashes when starting 3 or more build templates at the same time


#1

Summary:

Game crashes when starting 3 or more build templates at the same time.Hard crash to desktop.

Stonehearth.log:

Don’t have one.

Attachments:

Uploaded!

Versions and Mods:

Version 1.0 and and mostly just templates.

System Information:

Windows 10, GTX 770, AMD FX8350, 8GB Ram, dual monitor setup 1080p.crash.dmp (274.1 KB)


#2

Hey @Acek94, welcome to the forum! :slightly_smiling_face:

You should be able to upload files now.
Do you have a savefile from before the crash, where we can reproduce the issue?
Did you order several templates to start building while the game was paused or running?

The stonehearth.log can be found in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth
If you still have the one from after the crash, that’d be useful (it gets overwritten every time you start a new game).

We can’t reproduce this yet so any details on how did it happen are welcome (like, which templates were you using? Was this at the beginning of a new game or in an advanced town? Did any of the templates use modded items?,etc).


#3

Hi, thanks for the reply. :slight_smile:

I do have the old save and I’m not sure how to upload it here.

I don’t have the .log file (we started another game)

I like to plan with templates so I’ll place a bunch and plan my city around, then sometimes I’ll start construction of multiple at the same time, then it’ll do a hard crash with no error messages.

I generally have problems where like 4ish hours into the game things slow down and AI sometimes becomes unresponsive. For example, I’d send a unit of 5 soldiers and 1 cleric to attack an non of them move, they just keep walking around. I generally play multiplayer with my friend and this happens in just about every map we play. We play for a consecutive bunch of hours till it’s buggy and then we start a new one.

Just for the sake of being clear, these are the settings I play on.

*Fullscreen
*V-Sync
*High or Utra preset (start of the game is at 60fps but as it goes on I slowly drop, usually to around 12 or so)
*Ambient Occlusion, Anti Aliasing, speech bubble icons are all checked.
*Force 32 bit NOT checked.
*Auto loot, Auto Rescue, Auto queue all checked.
*Max citizens 80 (never get more than 26 before game just becomes unplayable)
*Enable Game Speed 3 ( I usually play on this speed all the time)

If you have an optimal settings for me to play at or how I should play to prevent bugs and crashes, please let me know.


#4

Hey @Acek94, sorry it took long to come back to this, I hope you still have the savefile.
How to upload savefiles:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be named a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.