Game Crashes when selecting the Quit to Main Menu button on the Customize your party screen

Game Crashes :

Steps to reproduce:

  1. Launch Stonehearth
  2. Click on new game
  3. Select The ascendancy, tempterate, and normal
  4. Click select Roster
  5. Click quit to main menu
  6. Game crashes

Expected Result:

Getting back to the main menu

Actual Result:
Error message:

Assertion Failed: sceneld < _scenes.size()(C:\rb\ihome\root\SH-OB0-Build\stonehearth\source\horde3d\Source\Horde3DEngine\egScene.cpp:1550

Not a big problem but I decided to post it anyways

Since I cant add attachments heres a link to the video showing off the crash :

Version Number and Mods in use:
No mods Stonehearth 0.21.0 (release 703) x64 build

System Information:
Dont know if any of this is relevant but whatever:
Windows 10.0.14393 Build 14393
System Model Acer Predator G3-710
x64-Based PC

Welcome to the forum :slight_smile:

Is it happening every time you go to menu from the customization screen?
Or only sometimes?

I tried it a few times and yeah seems to happen every time. although I think it doesnt happen if you wait on that specific menu for a bit

1 Like

This has happened to me too, although it’s not consistent, and it happens when I quit to the main menu after loading into a save. Same error, but the cpp number is different.

1 Like

Which one is it, in your case?

1539, every time. (Or at least the last three times)

Two additional questions for you @N1ntendick:

  1. Do you have a dedicated graphics card in your system or are you using the integrated graphics from your CPU?
  2. Can you check if you have a crash.dmp file in your Stonehearth directory? Assuming a Steam install, that would default to C:\Program Files (x86)\Steam\steamapps\common\Stonehearth. Please upload it (you’re no longer a new user so it’s allowed now :smiley:) so we can have more details.
  1. Using a nvidia gtx 1070 so no not internal
  2. I did not install Steam on the default folder but on my secondary hard drive. also I cant upload the post since im at work for the next couple of hours
    Will upload it asap if its there
1 Like

No need to rush - the devs are all out of the office by now…also, with a NVIDIA card, can you verify the exact driver version please?

Driver version is 378.92 also I found a crash_reporter.exe but no crash.dmp file :confused:

1 Like

Thanks for the details @N1ntendick. I highly doubt it’s the issue, but a quick heads up that there is a newer driver version for your card (as of yesterday). Hopefully, @Relyss and the team can give you a better answer - crashing is no fun!

There seems to be some kind of conflict between the rendering going on and the Quit to Main Menu command :disappointed_relieved:

We were able to repro, so thanks for the steps! :smile:


I saw the newest driver yeah just updated it its not a problem for me just thougt I would report it so you know it exists

1 Like

This should be fixed in the latest stable. Feel free to bump if you see it again. :slight_smile:

Alright Thank you :slight_smile: