Game crashes, no warning (CPP AI and Subspace Pathfinder were off)

I have the newest version of the game. I’ve tried starting new towns but I get about five minutes into the game and it will close. There are no warning messages or crash reports or anything. I’m not sure how to fix this or even what information you need. I really like this game and I want to continue playing. Please fix this!

Hey there @Saiomi, welcome to the Discourse! Sorry to hear that you’re having crashes while attempting to start a new town, let’s see if we can figure out what is going on. Can you upload your stonehearth.log from the main game directory here to the Discourse? Also, if there is a crash.dmp file there, please upload that as well.

1 Like

I cannot access any of the game files. I bought it through steam if that helps. Where would these files be located on my computer? I tried searching my hard drive for stonehearth.log and crash.dmp but nothing came up

Steam/SteamApps/common/Stonehearth is the path :metro: to take for any file you’re looking for

1 Like

Yep! As @Powerclank said, the default Stonehearth Steam path is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth. Please note, if you have modified the Steam install location, or use multiple hard drives, the path might be slightly different.

crash.dmp (164.8 KB)

Not finding any file named stonehearth.log though. I have a stonehearth.json file though.

Does not make any sense to me that you have a crash.dmp but no stonehearth.log. (Not blaming you…just odd :smiley:). Do you have a user_settings.json file there? Can you copy its contents here (it is just a text file, so you should be able to open it in something like Notepad)?

"user_id" : "48a18dcf-8ee9-11e5-a907-d4bed964c8ff",
"mods" : {
	"stonehearth" : {
		"enable_cpp_ai" : false,
		"enable_speed_three" : false,
		"default_storage_filter_none" : false,
		"max_citizens" : 40
"simulation" : {
	"use_subspace_pathfinder" : false
"config_id" : 1,
"collect_analytics" : true,
"alpha_welcome" : {
	"hide" : true
"tutorial" : {
	"hideStartingTutorial" : true
"enable_auto_save" : true,
"renderer" : {
	"run_once" : true,
	"use_high_quality" : false,
	"enable_ssao" : false,
	"enable_shadows" : true,
	"msaa_samples" : 0,
	"shadow_quality" : 1,
	"max_lights" : 50,
	"enable_vsync" : false,
	"enable_fullscreen" : true,
	"screen_width" : 1366,
	"screen_height" : 706,
	"draw_distance" : 1000,
	"last_window_x" : -8,
	"last_window_y" : -8,
	"last_screen_x" : 8,
	"last_screen_y" : 52
"audio" : {
	"bgm_volume" : 1,
	"efx_volume" : 1
"force_32_bit" : false,
"language" : "en"

That looks complete…unfortunately you are likely going to need to wait for @albert or another dev to return on Monday to troubleshoot with you further, unless @8BitCrab, @SteveAdamo, or @Relyss are around and have more ideas… :frowning:

There is a Stonehearth notepad doc. Would that help you out at all?

That is likely the stonehearth.log file, so yes please, upload that too! The more info the better.

stonehearth.log (25.9 KB)


Can anyone actually help me with my issue or did I just buy a broken game?

Hi Saiomi,
I am sorry no one has gotten back to you in awhile, I am new here to but I’d like to take a crack at this. First, when you launch the game be sure to check your settings so that the CPP AI and Subspace Pathfinder are Enabled. If they are, I’d like you to force 32bit mode and restart the game client. Once you have done this, start a new town and see how long it lasts before it crashes. If it doesn’t crash great, if it does please post the new stonehearth.log here. Thanks for your patients and remember that the game is still in Alpha testing so there is a lot to find and fix.

1 Like

Hey again @Saiomi, sorry about the delay…looks like this post slipped through the cracks over Thanksgiving. @Rezo2012 suggestion to check that CPP AI and the Subspace Pathfinder are enabled (they appear disabled based on your user_settings.json you posted above). Those settings are supposed to be on by default at this time, and with the continued development of the pathfinder in particular, crashes are likely if it is disabled.

Thank you for finally getting me help! It’s back up and running. Thanks!!!

1 Like

Glad we could help Saiomi.