Game crashes at specific point - bad_alloc

@Ponder, I’m getting this too (7+gigs ram usage @ about 50% CPU) as well as a 212meg save game file. :grimacing:

@SirAstrix, my specs are posted several places here, but it’s a higher end gaming AMD rig with 16gig ram and 4 gig NVIDIA video card and a fast 1T hard drive. To date it can handle anything I throw at it (except this game, haha)

2 Likes

Version : 240 Alpha 9

It is my 17° buiding, the floor created, the wall only one lvl
Crash after the 2° level.

It append all the time after 17° buiding.

Welcome to the forum, @artifus! :smile:

Could you try what is suggested in this post:

and see if you don’t get the crash?
Thanks for reporting.

I can confirm some bad allocation in 240 as well (although I’ve misplaced the actual data from the screen!). I’ve since applied @Ponder’s recommendation of disabling the Lua JIT, and so far, I haven’t seen anything come back up.

Granted, the game in question involves a very large structure with multiple floors and layered slabs, so I’m not surprised if it’s giving the game engine trouble. If anything else comes up, I’ll try to post the information.

2 Likes

So I happened to make it even worse. My save file is now 285mb, which I can’t load the file anymore because there isn’t a buffer big enough :smile: and I just before I saved for the last time and exited I was running at 9.75 gig of ram with a CPU load generally around 50% idle, probably because I refused to get more than 12 Hearthlings.

I’m really sad I never got to even start my epic statue I spent 3 hours designing, I did save the template though!

Here’s the last screenshot the save game kept for some minor reference.

Nobody was ever getting stuck or failing to find tasks, was running generally fine except for the high memory usuage unlike my previous settlement that was very similar to this one but with 30 Hearthlings and probably around 50 Goblins that had spawned and stayed stuck in their camp.

Thanks, works fine now.

Question : where i can post little bug with image ? Have you a post for this ?
Example : Man eating up n the chair. :slight_smile:

1 Like

Hi, I still have the bug.
Dev build 240.
error in lua allocator attempting to allocate 56 bytes
(boost::interprocess::bad_alloc)
5 CPUs (AMD system), 12GB memory…
Let’s ssee if it gets better disabling the JIT.
Daniel

ok, turning off Lua JIT helps here as well…

1 Like

After encountering this bug a few times now I decided to finally join the forum and report it!

I noticed some people reporting the Idle bug, but maybe this crash will reveal more information about it.

I can’t really say why or when the hearthlings stopped moving. I do know what didn’t help:

  • Moving stuff around them
  • Turning defense mode on and off
  • Trying to build new things (to give them a goal in life)

I decided to just keep it running - and eventually when night fell they went back to their daily lives!

However I’m attaching 2 images that might help pin point this issue:

  • The usage thing
  • A crash I got a couple of minutes after they went out of idle state (error in lua allocator attempting to allocate 524288 bytes (boost::interprocess::bad_alloc))
    Well I wanted to upload the images, but apparently “new users can’t upload images”… Bummer.

Ev

try uploading them so external site, i’ll put them here for you

Thanks!

Here are both images:

And

By the way - the LUA crash happens all the time - about once every few minutes now.
Might be related to the number of hearthlings I have (12 right now).

Well unfortunately the crash now happens moments after I load up my savegame… So it became unplayable. It’s a shame!

I’m happy to share any logs or savegame files if that could help in any way.

the lua crash is a different bugg which has already been confirmed and can be solved. by changing a setting.

here are the pics:
first:

second:

Hi,
Welcome to the forum. When you first load the game under system settings you can choose to disable the (lua JIT) This should allow you to load your game and continue playing. Its a known pathfinder bug and they are working on it.
Goodluck

1 Like

YES This seems to have solved it. Thank you very much! I guess I need to work on my forum searching skills.

2 Likes

I’m getting a very similar error (the ony difference being the number of bytes), but unfortunately I’m not seeing this “(lua JIT)” option in the settings panel on the title screen.

Hey!

The setting should be under options, System.

What Version are you currently using?
This was added on the latest build so if you’re using Alpha 8 that’s probably why.

Hope this helped in some way :stuck_out_tongue: