A bug that crashes my game entirely

Theres a bug that completely crashes my game without warning. Before this happened, I got this message error: release-559 (x32)
std::exception: 'bad allocation’
stack traceback:
[C]: ?
[C]: ?
[C]: ?
…nehearth/services/client/hilight/hilight_service.lua:76: in function ‘_on_frame’
…nehearth/services/client/hilight/hilight_service.lua:21: in function <…nehearth/services/client/hilight/hilight_service.lua:20>

I tried to open it back up, then 5 minutes later this came up: release-559 (x32)
c++ exception: lua runtime error
stack traceback: and I crash AGAIN! I want a solution QUICKLY im getting VERY ANNOYED!

Sorry for getting annoyed, I got angry because it was difficult to play.

Please calm down, @DarkStorm. Nothing will get solved by being annoyed. :sweat:

Go to your Stonehearth folder and upload the stonehearth.log file here so we can take a better look.

What was happening in game when this happened? If you have the savefile, please upload it too so we can reproduce the crash and find the cause.

Another question: why are you using the 32bit version now? In your other bug report you were using the 64bit version. Can you load different saves or new games fine? Is this crash happening only for a certain savefile?

Bad allocation means the game has run out of memory. Is your computer able to run the game in 64 bit? If so, please switch to using 64 bit.
Thank you

It seemed at random moments. All my workers were building houses gaurds were patrolling nothing special was happening. Also I am using 32 bit because I heard it may help with lag/crashing, but there is no diffrence so ill go back to 64 bit soon.

stonehearth.log (359.3 KB)

where did you hear that? as i’m pretty sure it’s the opposite way around… then again i don’t know for certain so i should stop spreading rumors :stuck_out_tongue:

I believe this was something that might have had merit 2 years ago. I highly highly recommend 64 bit now. It is actually what will fix this particular crash :slight_smile: