Engine Error Help

a22r735
building

#1

Summary:
I start up and continue my game, but upon loading the save file I come up with this Engine Error:

release-735 (x64)[M]
…mod/components/dehydration/dehydration_component.lua:52: attempt to call field ‘think’ (a nil value)
stack traceback:
radiant/modules/common.lua:245: in function 'report_traceback’
radiant/modules/common.lua:256: in function ‘think’
…mod/components/dehydration/dehydration_component.lua:52: in function ‘_adjust_status’
…mod/components/dehydration/dehydration_component.lua:17: in function 'obj’
radiant/modules/events.lua:83: in function 'instance’
radiant/modules/events.lua:291: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
radiant/modules/events.lua:285: in function <radiant/modules/events.lua:251>

Steps to reproduce:

  1. Play and make a civilzation
  2. Save Game
  3. Load up game

Expected Results
Engine Error pops up right after load up

Actual Results:
Same as expected

Notes:
Also… not sure if this Engine Error has anything to do with this but… my Hearthlings won’t work on this unfinished building when I loaded my game either :frowning:

Attachments:

Version Number and Mods in use:
release - 735 (x64) [M]

System Information:
OS Name Microsoft Windows 10 Home
Version 10.0.15063 Build 15063
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-FSTJHCM
System Manufacturer Dell Inc.
System Model Inspiron 3847
System Type x64-based PC
System SKU 0622
Processor Intel® Core™ i5-4460 CPU @ 3.20GHz, 3201 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date Dell Inc. A08, 6/29/2015
SMBIOS Version 2.7
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Dell Inc.
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.15063.0"
User Name DESKTOP-FSTJHCM\villania
Time Zone Central Daylight Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.92 GB
Available Physical Memory 1.41 GB
Total Virtual Memory 27.2 GB
Available Virtual Memory 15.9 GB
Page File Space 19.2 GB
Page File C:\pagefile.sys
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, Disabled by policy, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes


#2

Engine Error 1

release-735 (x64)[M]
stonehearth/components/scaffolding/scaffolding.lua:316: attempt to index field ‘_blueprint’ (a nil value)
stack traceback:
[C]: ?
stonehearth/components/scaffolding/scaffolding.lua:316: in function 'get_blueprint_region’
stonehearth/components/scaffolding/scaffolding.lua:357: in function ‘set_scaffolding_region_as_destroying’
…hearth/components/scaffolding/scaffolding_region.lua:752: in function ‘_start_erasing’
…hearth/components/scaffolding/scaffolding_region.lua:227: in function <…hearth/components/scaffolding/scaffolding_region.lua:220>

Engine Error 2

release-735 (x64)[M]
c++ exception: lua runtime error
stack traceback:

Engine Error 3

Same error as very beginning of this post

Anyway… There’s also this scaffolding problem. Look at it in all its glory:

I tried command > destroy (also destroy_scaffolding) but nothing is working.


#3

To use the destroy command you have to select the entity (in this case, a piece of scaffolding) before executing the command.

The first error you posted is caused by a mod (probably the cafe mod). The other ones are related to building.

That’s so much scaffolding :disappointed_relieved:
When removing unfinished buildings sometimes the scaffolding remains. They probably couldn’t reach a piece of scaffolding or ladder in order to remove it.


#4

Is there a recommendation for this? :frowning:


#5

For unfinished buildings, look for a ladder or piece of scaffolding that is on an unreachable place (for example, on top of other object, be it a house, a berry bush, a container…). Make a ladder so that hearthlings can reach it and remove it.

For all that scaffolding… if you are tired of selecting individual ladders and destroying them, go to a previous savefile if you have it.

If you have one of the building not being built (before trying to remove it), you can upload it and we can find where they are stuck.