Engine Error All the Time

Hello everybody

Whenever I try to build a custom house I receive an engine error. Everything is just fine until I start to build the roof. After receiving the engine error settlers basically stop building anything. The game right now is not playable for me. Is there any solution for that?

I am sick of using same building templates that game is offering us. Its not fun anymore…


Hello @elenixantom, thanks for posting this. This happened to me several times too, but not with the roof. I simply couldn’t just put the template or keep building. Sometimes when I save and load the game, it seems to fix that.
Did you tried that already?

hey there @elenixantom, welcome to the discourse :smile:

could you perhaps copy/paste the error here in a reply? knowing what the error is might help the team find the problem and fix the bug.

Most buildings should now build. Can you post a screenshot?

@Lawfer yeah I tried to load the game many times but still getting the same error. I will post a screenshot about that. Thanks for helping

does this happen when you try building on a new save?

could you post your building template? (stonehearth folder -> building_templates -> name.json)

@jjshab Yes, it does not matter whether its a new game or from previous betas. I never saved the buildings since I received engine errors. I simply load the game and use a template that game is offering or leave playing the game…

Something is wrong (maybe some file got corrupted?). On the first picture, that’s not even a valid color. :confused:

You don’t have any mods, so it should be working fine. Could you validate the integrity of the game cache on Steam?

1 Like

The lumber mill is a user submitted template, that I have used quite often. Do you think the issue is that its creator was using the terrain_color mod when they created it. Since @elenixantom is not using any mods that might be the conflict?

I run the terrain_color mod and have not had any issues with that template.

edit: the templete can be found at the StoneHearth Builds site http://stonehearthbuilds.esy.es/

If the template doesn’t use a terrain color, it should work.
The thing is, the error about the entry for the color, would be a valid and fixable error if the color existed in some mod. But the code mentioned ( 6643807 ) doesn’t look like a hex color, it has seven digits.

Well, when I started to get the engine error at picture 2, (since I can not build my own templates) I downloaded some building templates and started to use them. I do not have any mods thus I may receive the first error because of that. However I still receive the 2nd error. So basically it is still not playable for me.

I know that when I have excluded the terrain_color mod I have received similar errors for building I have created using the extra color, I see what you are talking about (the non hex color)

Could you point us to those templates? If you know of one that throws the second error, that’d be useful for us, to reproduce the bug.

1 Like

Another bug I have just received… You can see what kind of building I am trying to build. It has quite a simple structure…I got this error when I clicked to roof section

I have not tried using a negative roof offset, I will see if I can reproduce this one.

@Geokhan It does not matter my friend. I always receive this error no matter what. And then settlers stop building…

Well I just tried to recreate what was in your picture and received the following error.

So that one has to do with free-standing walls perhaps?