Engaged in combat Bug

I send troops to battle (to fight a small goblin camp) by using the fight marker on the enemy camp. However, once the armed goblins are dead, my footmen, knight archer and cleric (3 footmen, 1 archer, 1 cleric, 1 knight) stand in fighting positions but do not continue the attack.Summary:

Steps to reproduce:

  1. I use the red attack marker on an enemy camp
  2. My Soldiers attack any hostile troops which attack them

Expected Results:
They continue to attack the remaining hearth tenders and buildings, finish off by killing the camp fire and any remaining buildings and leaving to go home.
Actual Results:
They stand round, not attacking any non-hostile enemies, in an attack stance as if fighting but they don’t fight and only go home when I tell them to manually.
I cannot get them to attack at all. If I make them walk towards the goblin camp in question then attack, they go back to standing still in attack positions.

Version Number and Mods in use:
No mods, the latest version available on steam (not beta content, the normal game)
System Information:
Intel i5 quad core, GeForce 750 Ti, Gigabyte Motherboard, pretty rubbish 2003 Samsung monitor 4:3 17"

Currently you can’t attack if the enemy is not hostile. It’s like this by design. The goblin camp remains “neutral” or “friendly” until the campaign progresses and you make decisions to annoy them.

What it might be a bug is that they actually go to the camp and keep the fighting stance.

I can’t seem to reproduce this on Alpha 17 unstable, they come home automatically when they reach the banner on the camp.

Thank you very much for your help, it has reassured me a lot. I have not played the game since closing down the game after this bug, maybe it is a case of restarting. I forgot to say that at the time my game crashed four times (thank god for the auto save feature), maybe just a PC or Memory Glitch mucking up. There was a Windows update too, I will play the game soon and see if this is still the case. Are corrupted save files a thing in this game? If so I will just delete the save. Furthermore my troops attacked and killed the enemy armed goblins. Surely when a base is neutral they will not fight at all? I have disagreed with the current goblins demands so we are already at war. However I cannot attack his village, only his troops.

If you still have the save where this problem is happening, could you upload it here so we can take a look? If it’s too big you might need to upload it to a free hosting site like Dropbox or Google Drive.

Thank you for all your help and time, my problem has been solved. I demoted the footmen to normal workers (who obviously will not be engaged in combat) so they wandered off to the mine. Then I promoted them back to footmen and they went and attacked the camp normally. Although this is frustrating because I have 5 footmen (all level 2) and a level 1 herbalist, it has solved my problem and I can get on nicely now. Thanks for your help!

**Summary: Bug with goblin enemies **

Steps to reproduce:

  1. The goblin camp appeared near to my village
  2. I tried to attack them

Expected Results: Attack goblins

Actual Results: Goblins can`t be attacked and not attack me

Notes: maybe tht`s not a bug


Version Number and Mods in use: No modes

System Information:

The goblins (if part of the campaign) will not attack you until you decline their offer. Otherwise just wait until they become aggressive towards you, I’m not sure whether it is a bug or not because sometimes I can attack goblin villages, sometimes not. Wait it out, otherwise contact an Admin or something.