[Dup] Bug: Stonehearth Assertion Failed

e2d85dd4-59d1-11e5-bd31-14dae94e014d, version 0.11.0 (develop 2598) x64 build.

When I tried to build a “Shard Sleeping Quarters”, I was spammed with dozens and dozens of assert error dialogs, immediately after clicking on the quarters entry in the 'Building Templates" window. They continued to spam, until I closed the game via the windows ‘X’ frame button. If I tried to close one, another appeared immediately.

The actual assert dialog title was “Stonehearth Assertion Failed”, and the ! message was “Assertion Failed: false(C:\rb\ihome\root\SH-OB-BUILD\stonehearth\source\csg/rotate_shape.h:249)”

I have a screenshot that shows the bug. It shows that in the “Building Templates” window, the 'Cottage for Two" has a bright selection background, and the “Tiny Cottage” as a dimmer selection background. I was moving the mouse away after having clicked on the “Shared Sleeping Quarters” selection.

A post was merged into an existing topic: Assertion error develop 2494