Assertion error develop 2494

IOn the new develop 2494 after about an hour i get the following error each time.

Assertion fail: false ( c:\rb\root\sh-ob-build\stonehearth\source\csg\rotate_shape.h:237


Thanks! I’ll get this fixed.


I’ve also seen this. Once it first popped up, it kept popping up after I closed it until I had to close Stonehearth itself.

1 Like

[v0.11.0 - Dev-2598 - x64]
Ran into this error when trying to place a Cottage for Two for construction. It spammed out the error on the screenshot constantly and had to use the task manager to close the game. Clicking the “Ok” button didn’t do anything as it just gave me another. I’m not sure what caused it to happen, it just happened when trying to place another house after I build 3 others and a Dining Hall. I havn’t run into this yet after starting a new game after this happened.

I got this as well with the same building. After reloading a few times I got it to work.

If you post or email us the save game, I can get this fixed. Thanks!

1 Like

so sad :frowning: sometimes the game unexpectedly crashes… see the error message in the upload:

e2d85dd4-59d1-11e5-bd31-14dae94e014d, version 0.11.0 (develop 2598) x64 build.

When I tried to build a “Shard Sleeping Quarters”, I was spammed with dozens and dozens of assert error dialogs, immediately after clicking on the quarters entry in the 'Building Templates" window. They continued to spam, until I closed the game via the windows ‘X’ frame button. If I tried to close one, another appeared immediately.

The actual assert dialog title was “Stonehearth Assertion Failed”, and the ! message was “Assertion Failed: false(C:\rb\ihome\root\SH-OB-BUILD\stonehearth\source\csg/rotate_shape.h:249)”

I have a screenshot that shows the bug. It shows that in the “Building Templates” window, the 'Cottage for Two" has a bright selection background, and the “Tiny Cottage” as a dimmer selection background. I was moving the mouse away after having clicked on the “Shared Sleeping Quarters” selection.

@jonzoid - Do you still have this save?

Emailing now! :smiley:

I would have shown a screenshot, but I had an error show shortly after. Upon clearing a foundation area where a bugged building was, I found that a transparent blue block appeared and would only allow me to remove or start the building operation. I tried both, but was unable to complete either. Shortly after i was taken to the desktop and prompted with this error.

      "Assertion Failed: