Display driver AMD stopped responding and has recovered

Hi Everyone!

This is my first post on this group. Good to be here. I am enjoying what I have seen of this game! I am glad to be a supporter!

First, My Rig:
Windows 7 Professional 64-bit
Intel Core i7 CPU
DirectX 11
ATI Radeon HD 4600

  • I have two video cards, and was playing with them liked in CrossFire mode, but game was crashing frequently, so I turned CrossFire off. Still crashes, see below, but not as often.

Second, Drivers:
I have checked and all video drivers are up to date. Also just ran Windows Update.

Third, Symptoms:
I play for a few minutes, then the game freezes and I get this message in a pop-up window:
Display driver AMD stopped responding and has recovered

After this message, the game goes into “Not Responding” mode. I can close the window, and launch the game again, picking up from where I saved, but the game stops responding after a few minutes and the next “Display driver AMD stopped responding and has recovered” message.

Any tips? AMD Drivers are up to date.

Again, very cool game. Thanks for all the effort you’ve put into it thus far!


hey there @raumac… welcome aboard! :smile:

thanks for the detailed breakdown of the issue you’re facing … can you also let us know which version you’re playing (humble bundle, steam)?

other than that, paging @not_owen_wilson! :wink:

I’m starting to wonder if the game doesn’t have heartburn with AMD chips in general…

I tried to load the game on my Secondary Rig, but running into issues. It occurs to me that this game may not allow me to install it on two PCs, so if that is the issue, ignore the rest of this post! :smiley:

First, My Secondary Rig:
OS - Windows XP Professional (5.1, Build 2600)
CPU - AMD Athlon 64 x2 Dual Core Processor 4200+
DirectX - DirectX 9.0c
Video Card - GeForce GT 630

Game seems to be installed, but when I click “Play” I get the message,
“Failed to start game (unknown error).”

I tried to download the installer from my Humble Bundle Link, but get the error message,
"[File] could not be saved, because the source file could not be read."

Hope this information is useful to you.


Hello, hello! :smiley:

Please, see this thread and try workarounds:

Tell us if it works!

not to keep a linked thread going, but just to say… i have realtek or w/e its called, but i have a radeon R7 200 series (which is mainly amd/ati) and mine works absolutely fine

my specs:
ASUS M11AD mobo
quad core i5
8 gb ram
1.2 Vram (on the graph card)
Dx 11

@relyss That did certainly look exactly like the bug I am experiencing… even the “Music continues to play, and the game remains open for ~10 seconds though it’s nothing but an empty white window.” (except my window stays open and does not go away until I close it)

So I turned CrossFire back on, then changed “Stonehearth.exe” to “SeriousSam.exe”.

The game launched, but after a few minutes (ran longer than usual) I could not assign a new job to my workers. I had made a trapper, but when I went to assign a carpenter, after clicking “new job” button, the job screen was just blank.

Also, saw a message in the upper right corner (new window?) which said something about “children unassigned”, and then …

the game crashed my entire computer.

Blue Screen of Death with a Memory Dump.

I was able to reboot, and report my results.

I think I will change back to Stonehearth.exe, and give this game a break for a while.

Let me know if you have any other recommendations.

Thanks again for what appears to be an excellent game in development.


if you are using the steam build, try purging your files (delete local content) and then reinstall? and it will force an update… that NORMALLY works

oh sorry caps, im running on fumes

I can only use Steam on Secondary Rig, since I cannot download installer from Humble Bundle link on second machine. So I tried “Delete Local Content” and reinstalling (on Secondary Rig). Got a message that installation was corrupt. Deleted Local Content again. Reinstalled, and Stonehearth said it was “queued”. Let it run all night, hoping it would queue.

This morning, no “queued” message! Tried to launch game and got the “Failed to start game (unknown error)” message.

To circle back to an earlier question, should I be able to install on a second machine, or is this all doomed to fail due to license restrictions? I have not uninstalled (via Steam or otherwise) on my main machine.


yes, you should be able to do so, trough steam at least. I have it installed on 3 devices xD
Have you opened the log-file from stonehearth to see if there’s anything special popping up?

Not sure if I should start a new thread, but I did mange to get Stonehearth installed on my Secondary Rig… sort of.

First, My Secondary Rig:
OS - Windows XP Professional (5.1, Build 2600)
CPU - AMD Athlon 64 x2 Dual Core Processor 4200+
DirectX - DirectX 9.0c
Video Card - GeForce GT 630

I have installed it via Steam, as well as downloading the installer and the zip.

Steam Stonehearth never launches; it just gives the message “unknown error.”

I tried installing via the downloaded installer and via the downloaded zip file. I’ve uninstalled, reinstalled, repaired, downloaded the install files again, over and over, but every time I try to launch the game I get the error message:
Stonehearth.exe is not a valid Win32 application.

I will search the discussions for this error, in case there is an easy fix. But I wanted to update this tread.

Thanks again for all your work on this game. I hope to someday play it!

Never Mind! I just found this:

sdeeTeam Radiant Sep '14

Hey @andrey,
the game does not run on Windows XP at the moment. We would like to get
it to run, but the compile errors are so numerous and obscure that
we’re not sure when we will have time to circle back and optimize for
that platform.

Back to me (@raumac) since Microsoft is no longer supporting WinXP maybe it is finally time I bite the bullet and upgrade my secondary rig.

Still not sure why it keeps crashing on my primary rig, although I think a someone (@NonBritGit) mentioned that AMD chips might be the problem, while @Barney324 may disagree.

I will keep trying!

Thanks again!

1 Like

I read that you deleted it from Steam, but did you go and actually remove all the folders physically from your steam folder or just use the steam client method of “delete local content”? Try manually deleting the entire Stonehearth folder then the delete local content from steam method and try downloading it fresh only from steam.

Also, if you have the Humble Bundle files anywhere, delete those too. I ran into real troubles when I downloaded the Humble Bundle files and then the Steam version. While they do not download to the same location on my computer, I was getting freeze/crashes whenever I would try to save game but that was Alpha 8 when I tried to go from Alpha 8 to Alpha 9 (still in testing) via Steam. If you’re only trying to run the Alpha 8 from Steam it should work fine just don’t try to run it from Steam after downloading the Humble Bundle version.

1 Like

New release has fix it! No longer crashing, and can play games for hours (and hours and hours) now without a crash. Tons of Fun!

Thank you!

1 Like

That is on Win 7 machine. I have not checked if new release works on WinXP, but based on sdee’s comment I quoted above, not going to check.

1 Like