DEVELOP-2871 (x64) - UI Error


I experienced a UI error, leading me not able to get new Hearthlings, place objects, or really just do much of anything.

However, I was able to refresh the UI with the ‘F5’ key, and save the game. But after the loading the game up, none of the command options loaded on-screen. The game was still running, and my Hearthlings were still performing previously commanded tasks, but I just wasn’t able to do anything else.

Also, just to note… this saved game / bug was from the previous patch, DEVELOP-2867 (x64), and is still present just after downloading the newest DEVELOP-2871 (x64) patch.

Steps to reproduce:

Yet again, unfortunately, I’m not sure how to reproduce this bug.

However, my best guess would be due to the large farm zones that I have setup combined with my system performance.

Attachments: (7.8 MB)

Version Number and Mods in use:

Version - Alpha 15 DEVELOP-2871 (x64)

System Information:

Unfortunately again, I’m an idiot. I’m probably the only college student who doesn’t know how to do this, but I’m not sure where to go to find this information. However, if I find out how, I’d be more than happy to edit that information in later if need be.

Hope this helps!


(Note: While I had the game running with no command options… options such as “Harvest,” “Build and Design,” those sorts of things… after a while, I refreshed the UI again with ‘F5’ and it seemed to have worked and repaired the error. I’m able to give out commands now, but I’m still not able to get new Hearthlings.

My two cents - it appears that after my farmers completed planting the crops, I was able to successfully refresh the UI.)

Hi there,
I’ve put in a fix for this. It will make the UI show up in the saved game you’ve provided and make it mostly functional. Look for it in the next unstable a15 build.

1 Like


Wow, you guys are awesome!

Thanks Ms. Shan!