[Develop-2494] Seed generation impossible with some seeds

Sometimes when I write a seed to generate a specific world I get an error (out of the game).
It’s not for all the seed, this error happen only for this two :


When I write one of this two the generation get stuck on “Loading…”, and when I get back to Windows (with alt+escape or start) while the generation is loading this error appears :

Then clicking on OK close the game.
It’s not the case for the other seeds and I tried several times with the seeds above and always same error.
As a result I cannot play on the awesome valley I found ahah

So you wrote these seeds manually, they weren’t generated by code, right?

1 Like

i believe these are seeds from a previous playthrough, that were copied so that he could use those worlds again.


As said 8BitCrab I write down this seeds during my different session of “looking for a great map by rolling new map”. It was generated by the game :blush:

EDIT : Okay after another try it works out (for the second seed) just using copy/paste (don’t think it change anything ahah).
I let the topic active because of the error and the recurrence of it.


Sometimes when we “copy / paste” things from one site to another we get an extra “space” at the very end of the partial copy, example:

"1234567 "

Notice there’s a space after the 7, some programs might recognize this whole number as a different one. ( 8 digit = 7 + space )

Have you checked this?


not that it shouldn’t work across builds, but were the problematic seeds generated on the initial A11 release, and are failing on the updated A11 build, perhaps?


1 Like

Both of the seed come from the same alpha (the latest) I tried on.

I just tried to add an extra space after write the exact same seed (322375283) it doesn’t work !
-I tried to write another time the seed without space and use the copy/paste, it doesn’t work.
-I tried another time to copy/paste the seed (from my first post to the game) and weirdly it works again. It seems that copy/paste solve the problem.

Exact same problems with the first seed.

Am I the only one to have this problem ?

1 Like