[Dev Blog] Stonehearth Alpha r27 is up!


#1

edit: as there’s an official blog post for the release, i’m updating the thread…


http://stonehearth.net/2014/01/10/stonehearth-alpha-r27-is-up/

parent thread to house some of the random topics popping up about r27… we might continue this theme going forward for subsequent builds…

quick comment from me, full screen works like a charm! only problem is exiting the game… :smile:


Today's update on steam broke the game
R27 Update Is great for my graphics card now!
#2

Hi,
So I noticed a 24.6MB update at about 4:13pm (PST) today so I decided to try it out again.

However, now the game is broken in that I can no longer click on the banner that says to click on it to place the stockpile. My mouse cursor turns into a hand indicating it can be clicked but left clicking on the banner does nothing.

Just thought you might want to know as it’s completely borked now with todays update.

Cheers

P.S. Otherwise the update would be nice what with the new WASD movement keys.


#3

Okay, it has something to do with the resolution of the game. For some reason, now things have to be clicked on to the left side of the item, for example clicking on the banner that tells you to place a stockpile requires clicking on the far left side of the banner, clicking a tree and then clicking the axe to chop it requires clicking on the far left side of the axe icon etc.

So it’s not totally broken, you just have to adjust where you click for some reason. Perhaps it does not affect anybody else and it’s only my game that it’s happening to, I don’t know.

Edited: I wrote we have to click on the right side of items but it’s actually we have to click on the left side of items.


#4

So I played the game last night, R24 or something like that, and the game ran alright, but not much more then 15 fps. I get home tonight from work and see that there is an update for the game, R27. Now I’m getting frames at a much more tolerable 25 fps or so.

I just wanted to say thanks so much for the hard work you guys are putting into the releases. : ) I’m not worried about content at this point in time, just very surprised that I’ll be able to play it alright on this old machine. Thanks again!


#5

Hmm. What resolution is your monitor running at? Are you running full-screen, or in a window? Is the window maximized? More than one monitor?

Thanks.


#6

Release notes for it anywhere?


#7

Alt+F4 works great to exit the game from full screen :wink:

However, I’m wondering how you’re getting into full screen, are you editing the .json file? I’ve tried the usual Alt+enter keys but it doesn’t put the game into full screen like many other games do.


#8

My game always opens at 1080p if its in windowed, it doesn’t keep the previous changed resolution.
I tend to play at 900p so adjusting every time is getting slightly annoying. Game runs okay otherwise


#9

As in, you launch the game, manually resize the window, and exit normally, but on launching the game again, the window is 1080P again?


#10

No changelog? dam …


#11

It’s a pretty small update: just a fix to the fullscreen issue.


#12

There’s an in-game setting, if you click on Options in the title screen. It then requires a restart upon checking it. :slight_smile:


#13

I tried it out now 10 times in a row, it seems to work okay! It keeps the resized res.
But if I enter the game in fullscreen then disable it and restart then it opens in 1080p in windowed which is a bit pooped. I mean I will keep it windowed so it doesn’t bother me really but you could tell the game to downscale from fullscreen to the closest smaller proportional resolution (for 1080p would be 900p)


#14

Ah, I understand. A resolution picker for fullscreen is coming very soon…


#15

I seem to have forgotten those existed. Been playing too many alphas recently :blush:


#16

It is somewhat (about a week?) new to be fair to you…:wink:


#17

Hmm, there is no “options” option to click on in the title screen for me.


#18

What release does it say you are? It should say in the bottom right at the title screen.


#19

Can’t see the bottom right of the screen, it seems cut off. But it’s the release that introduced us being able to use the WASD keys to move around the map.


#20

I’m not sure I understand what you’re saying? xD I wanted to say that I completely forgot that games have resolution pickers cause all I’ve been playing are alphas that still don’t have that implemented