Crash on Loadout screen (Intel graphics drivers)

I run Stonehearth and select a new game. I choose my people (I tried with both races), my region, and my play style. I click to the next screen. The loadout screen shows up. It doesn’t allow me to click anything, and then moments later the game crashes to desktop.

Steps to reproduce:

  1. Run the game.
  2. Start a new game.
  3. Follow the prompts.

Expected Results:
I expected the game to let me choose my beginning equipment.

Actual Results:
It crashed to desktop.

I previously emailed the support about this bug, and they suggested I update my drivers. My drivers are up to date.

stonehearth.log (4.7 KB)

Version Number and Mods in use:
Alpha 14 release 524

System Information:
OS Name Microsoft Windows 8.1
Version 6.3.9600 Build 9600
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name HPENVY
System Manufacturer Hewlett-Packard
System Model HP ENVY TS 15 Notebook PC
System Type x64-based PC
System SKU E7Z43UA#ABA
Processor Intel® Core™ i5-4200M CPU @ 2.50GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date Insyde F.36, 10/24/2013
SMBIOS Version 2.7
Embedded Controller Version 147.73
BaseBoard Manufacturer Hewlett-Packard
BaseBoard Model Not Available
BaseBoard Name Base Board
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = “6.3.9600.17196”
User Name HPENVY\Chris
Time Zone Central Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.93 GB
Available Physical Memory 4.98 GB
Total Virtual Memory 9.18 GB
Available Virtual Memory 5.38 GB
Page File Space 1.25 GB
Page File C:\pagefile.sys
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware No
Hyper-V - Data Execution Protection Yes

Hmm…the log seems to indicate that the save game directory does not exist - I have not personally seen that error before.

What’s interesting is that you aren’t trying to save the game, but create a new game. Going to need a dev (like @Albert) to take a look, sorry I can’t be of more help :frowning:!

1 Like

@TheReborn - The crash report indicates that the crash is occurring inside the Intel graphics drivers. This string in the log shows that the drivers are over two years old:

OpenGL driver ‘4.2.0 - Build’ by ‘Intel’ on ‘Intel® HD Graphics 4600’

I assume you tried updating the drivers from this site:

but if that doesn’t help you may need to see if HP has an updated driver set for your machine.

1 Like

Thanks Albert. I guess I’ll be checking out HP for an update. I’ll update here once I’ve finished.