Craftsmen not working their assigned job

Craftsmen, especially carpenters and blacksmiths, ignore crafting orders in favor of restocking stockpiles.

No matter what I do, the craftsmen simply ignore my requests to build anything and instead do anything else, such as building and restocking stockpiles (the latter being the more prevalent).

To replicate this, simply tell a craftsmen to make an item while restocking or building is an option.

I expected the craftsmen to work their job BEFORE building or restocking etc.

I am using the build DEVELOP-2387 (64x) (latest dev build as of 4/29/2015).

Hope we can get these lazy guys back to work, the goblins are being rather aggressive…



Sometime items is floating in the air that they are using, They will then stop there task, to prevent that you have to build a ladder to the items that they use:

The Items will now fall to the anvil and the blacksmith can continue his work.

Here you can see it.

This is not the issue, for the resources in the stockpile they need to use are accessible to the other hearthings, they just seem to ignore this fact and act as though they are a worker.



Yes, I reported exactly what you’re describing a week or so ago.
Mason/blacksmith/carpenter going around picking up wood rather than crafting despite stockpiles having plenty of resources(nearby too, since if it’s a certain distance away they don’t get stuff from it)

1 Like

I do have the same problem. I thought it has something to do with moving the items in the queue (to another priority) or with the “craft until x in stock” option, but I could not reliably reproduce it.
Last time when my mason stopped working the orders ans started restocking piles or just being idle if there was nothing to restock I demoted him to a worker and then promoted him again to mason. This did the trick, he immediately started crafting again.
Same thing happened later to my carpenter and the same trick worked again, so it seems to be a reliable workaround, but it would be nice if this bug could be fixed.

Same problem here. I tried the solution as proposed by Aghork. It seemed to work at first since my level 4 blacksmith started looking for ingredients. However, that took only one second and he went back to idle (I stopped him from doing other thing than his job). I tried it twice, both times the same result… collecting ingredients… idle.
I tried clearing the job list, did not work either.
I assume that what is happening is that the ingredients are available but he can somehow not get to them.

EDIT: Finally found it, although it claims there is wood. My blacksmith could not find wood.

Hey there @bderooms, welcome to the Discourse! Just to check, did you determine this isn’t actually a bug, but there wasn’t the ingredients needed available?

Hey @jomaxro, well it was a less important bug. The UI showed that the wood was available every time, so it was hard to determine which ingredients were unreachable, but I assume this has been reported before. At the beginning of the game I had a similar issue, I started with a farmer tool and tried to make a farmer but no mather how many times I clicked on the promotion to farmer, the hearthling never went to get the tool. I did not find the tool myself either (when searching manually in my stockpile) although it was showing in the UI.

I wonder if it could be related to this:

Assuming you still have a non-functioning blacksmith, could you try running the command @yshan posted?

Having the same issue with the Mason not doing their job in release 524 (x64). The mason built their masonry craft table and then decided they had better things to do in life. I’ve tried several different methods to get them to do their job that I read on here: 1: promoting worker to mason, unpromoting them, and then giving them the job back 2: the dump_inaccessible_items code.

Then I stumbled on something interesting. I mined some stone out of the side of a hill. The mason immediately grabbed up the stone and made the queued fences. Scratching my head, I built some crates and removed the ground storage to tidy up my budding town. My workers moved everything BUT the stone I had stockpiled to the crates. In fact, they do nothing with them. I tried the dump_inaccessible_items code again but no dice, they’re just lumps of rock sitting in my town now. Maybe the ground storage is the cause of the masons, and possibly other craftsmen, not working? I gathered all of those stones long before I could make masons from the overworld rock blocks and collected from baby golems.

Hope this helps some and I beg pardon if someone else already made this observation!