Corrupt Auto-Save After Crash (Includes Save) - release 763


I had to momentarily step away from the computer (to get pizza, yay!) and when I returned the Windows screen saver had engaged. When the screen saver vanished I was met with a crash notice for Stonehearth (“Caused an error and will close, yadda yadda”). I went to load the last auto-save and the game immediately crashed as soon as the loading bar was full. Tried again, same result. It starts loading the save but when the bar reaches full the game crashes. Not all is lost, thankfully, as I do have a separate save that will, unfortunately, rewind me to 3 days earlier.


I’ve tried several restarts of the game, so the log from when the crash first occurred isn’t available. Sorry… :frowning:


World Save = Dropbox -

Hope you enjoy some of my building designs, assuming you can recover the save… :slight_smile:

Versions and Mods:

Using release 763 x64 ( with NO mods installed

System Information:

Windows 7 x64
AMD FX-8320 8Core CPU (3500Mhz)
Nvidia GeForce GTX 750 (don’t judge me, it runs games awesome)

Have you attempted basic troubleshooting steps here:

Yes, I have tried the basic troubleshooting steps. I believe the issue is a corrupt save, but not sure how it got corrupted other than the game possibly tried to write the save while the screensaver was enabled and somehow that caused the crash.


After closing out Stonehearth for about an hour, and loading it back up, I was actually able to get the save game to load. That said, when it started there was an “Engine Error” pop up. This is what showed in-game;

release-763 (x64)
…hearth/components/scaffolding/scaffolding_region.lua:1092: attempt to index field ‘_scaffolding_region’ (a nil value)
stack traceback:
radiant/modules/common.lua:245: in function 'report_traceback’
radiant/modules/common.lua:256: in function <radiant/modules/common.lua:250>
…hearth/components/scaffolding/scaffolding_region.lua:1092: in function ‘_update_scaffolding_size’
…hearth/components/scaffolding/scaffolding_region.lua:499: in function 'fn’
radiant/modules/events.lua:288: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
radiant/modules/events.lua:285: in function 'trigger’
radiant/modules/events.lua:370: in function '_fire_async_triggers’
radiant/modules/events.lua:445: in function '_update’
radiant/server.lua:61: in function <radiant/server.lua:58>


Further playing THIS save I’ve noticed that it appears an area of the map is “corrupt” in some way, yet I’ve been able to fix the corruption.

Prior to the afford-mentioned crash I had my Hearthlings crafting a guard rail around the edge of my plateau using the Building Designer. I believe the crash occurred during the construction of this guard rail. After I was able to get the save to load I noticed a section of guard rail (Screenshot: Bug Report Submission - Album on Imgur ) didn’t exist. I tried to create it again but was unable. It was as if the blocks were there, yet not there. Destroying the build didn’t seem to resolve the issue either, although I did notice that when the build was destroyed the section that was “invisible” also appeared to “blow up”.

Just by happenstance I placed some fence in that location, as I found I was able to do so. Later I removed the fence to give building the guard rail another try and I noticed something peculiar. As the Hearthlings removed the fence blocks they also seemed to stop and do a few extra hammer hits here and there, as if they were removing ladders or scaffolding that wasn’t visible. Even with the fence removed a few Harthlings still walked over and hammered out the removal of some invisible scaffold/ladders.

After this “self correction” by the Hearthlings, I performed a save and reloaded the save. The engine error that I had been getting still exists, but I was able to build in the area when I couldn’t before. It looks like the cause of the map corruption was some phantom scaffolding/ladders. Due to the engine error still occuring I have no doubt that some of those phantom scaffold/ladders still exist on my map, but lord knows where. I still can’t tell you what caused the initial crash though, sadly.

1 Like