Conversation bug


#1

Summary:

This popped up today - playing ACE plus a few other mods but it didn’t look like it came from a mod

release-947 (x64)[M]

…ctions/conversation/conversation_initiate_action.lua:50: attempt to compare nil with number

stack traceback: [C]: ? …ctions/conversation/conversation_initiate_action.lua:50: in function ‘_on_social_attr_changed’ …ctions/conversation/conversation_initiate_action.lua:16: in function <…ctions/conversation/conversation_initiate_action.lua:10> [C]: in function ‘start_thinking’ stonehearth/services/server/tasks/task_action.lua:102: in function ‘_start_stop_thinking’ stonehearth/services/server/tasks/task_action.lua:175: in function <stonehearth/services/server/tasks/task_action.lua:174> [C]: ? [C]: in function ‘trigger’ radiant/modules/events.lua:63: in function ‘_update’ radiant/server.lua:67: in function <radiant/server.lua:64>


#2

Save the game, close out Stonehearth completely. Relaunch and see if you get the same error.


#3

Yes same error after restart


#4

What mods do you have installed besides ACE? This seems to be a bug when two hearthlings are speaking to each other and it’s bugging out before they can even start their conversation


#5

Do you have any large animals tamed by a trapper? Or, in other words, do you have (or had) a Level 6 trapper with a big game trapping zone?

If so, it is possible that you got a big animal tamed as a pet. We fixed this issue today (preventing them from being tamed) because they are not supposed to be pets and lack a lot of the “pet features” like logic for conversations with hearthlings (when they play), town alarm, etc… so every time one of these is triggered, it can cause errors.

If you do have a large animal as pet, I’d recommend you release it :slight_smile:
If you don’t, then it’s probably something else :smiley:


#6

Yes I do have a boar - ok will release it thanks :slight_smile: