Im working on a less conversation mod and its not working

this is my mod
1362625330.zip (1007 Bytes)

it modifies base_human.json
{
“components”: {
“stonehearth:attributes”: {
“max_social_satisfaction”: {
“type”: “basic”,
“value”: 0
}
}
}
}

and constants.json
{
“constants”: {
“thought_bubble”: {
“priorities”: {
“CONVERSATION”: 5
}
}
}
}

to make it so Hearthlings converse less.
am I doing this wrong or are there more files that need to be modified in order for this mod to work?

You should just mod TALK_THRESHOLD in constants.json to something higher.

1 Like

I did this
{
“constants”: {
“social”: {
“MIN_SOCIAL_REFILL”: 68,
“TALK_THRESHOLD”: 960, “__comment”: “When social satisfaction falls below this threshold, hearthling will start considering conversing”,
“ANIMAL_TALK_THRESHOLD”: 768, “__comment”: “When an animal’s social satisfaction falls below this, a hearthling will try to talk to the animal”,
“PET_TALK_THRESHOLD”: 60,
“PET_FOLLOW_THRESHOLD”: 64,
“SOCIAL_LOSS_INTERVAL”: “30m”, “__comment”: “Entity will lose social at this interval. Loses social based on social_loss_amount attribute”,
“DEFAULT_SOCIAL_LOSS”: 0.1
}
}
}
but they still converse
possibly a way to disable conversations all together? @max99x

From the comment it looks like it should be the opposite, a low number.
I’m against cheat mods, I think it was even against the rules at some point. But if you really want, it would be easier to simple remove their conversation component.