[Confirmed] SGT2 Bug: Test shows only black screen

resolved

#1

Title: Graphics test shows only black screen

Summary: All I get is a black screen as follows.

The text is there, and highlights appear around bushes and such. I can move the camera around, as the highlights change position when I press and hold the right mouse button.

Steps to reproduce:

  1. This happens every time I run the game.

Expected Results: Able to see objects and characters

Actual Results: Not able to see objects and characters

Notes:

Attachments:

Versions and Mods: Graphics test 2

System Information:

OS Name Microsoft® Windows Vista™ Home Premium
Version 6.0.6002 Service Pack 2 Build 6002
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DANIEL-PC
System Manufacturer Sony Corporation
System Model VGN-FW11E
System Type X86-based PC
Processor Intel® Core™2 Duo CPU P8400 @ 2.26GHz, 2267 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. R0250Y0, 05/06/2008
SMBIOS Version 2.4
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2
Locale United Kingdom
Hardware Abstraction Layer Version = "6.0.6002.18005"
User Name Daniel-PC\Daniel
Time Zone GMT Standard Time
Installed Physical Memory (RAM) 3.00 GB
Total Physical Memory 3.00 GB
Available Physical Memory 1.28 GB
Total Virtual Memory 6.19 GB
Available Virtual Memory 4.16 GB
Page File Space 3.29 GB
Page File C:\pagefile.sys


#2

I quick look at the model you are using shows that you have a mobillity radeon HD3470 for your graphics chip (correct me if I’m wrong) this isn’t that powerful so its possible that’s why it isn’t working but try updating the drivers for it that might fix the issue.


#3

I have the same issue and I do have a mobility radeon HD3400 serie. Updating my driver as you suggested did not solved the problem.
*Yes it is old, but that usually is only a problem in power/speed.


Worrying about compatibility