[Con] World generation - floating trees / trees atop other trees

I just found a beautiful Ancient Tree, but it just floats and is not reachable. It seems that it spawned on top another tree.


Welcome aboard, @Tiavor! We hope you enjoy your stay!

Our mighty overlord, @SteveAdamo was suppose to be here to give you the oh so official welcome aboard speech, but again, he’s fashionably late, again, like last time, and the time before. :disappointed:

But watch out. Thar be monsters here! :japanese_goblin:

1 Like

Well, this bug is kinda common. I guess it is because of a bug in the terrain placing or something like that. It is not that severe, if it is at all. This bug should be fixed in the next bug release, so no worries! :smile:

Bye! Hope you enjoy your stay, if you stay here at all. :thumbsup:

thx. i know that it isn’t that severe. >_> just waving at the null-pointer exceptions that pop up every few minutes

Yeah, this is a known bug - mentioning @SteveAdamo so he can see this & merge it with the other thread (it’s almost 2am here so you’ll have to forgive my not finding it :stuck_out_tongue: ).

The only similar bug I found was the floating trees because one of their voxels was touching the ground of an upper ground level. I also remember clearly an ancient tree on top of a bunch of trees, but I can’t find it anywhere. Maybe it wasn’t posted in a bug report? There are so many now it’s difficult to search :persevere:

I had this problem in my mod. Its a collision box issue and easily solved.

apologies… out and about this weekend (road trip!)…

so, do we have a thread to merge with?

The algorithm probably tried to spawn a tree and was like “somethings in the way!!! shaize, i’ll just spawn it on top”

Floating tree! It was actually attached perched halfway up that wall on a ledge.

started the game, saw this
Build 2193 Latest, no mods

Trees and houses are badly placed when they are auto generated. I suspect it would happen for bushes also.

Yeah I found a slight issue with my Goblin camp


1 Like