[Con] Unable to promote Trapper 2283 (x64)

Have a level 4 trapper and still unable to promote him to Shepard

You can see the Shepard’s Crook below the job screen (next to harvest icon), made more crooks but it made no difference.

Windows 7 Home Premium 64-Bit
Alienware R4
Intel® Core™ i7-4820 CPU @ 3.70GHz 3.70GHz
GeForce GTX 760 (2)

and you have a level 3 trapper and you want to promote him (selected him)? because only he can promote to shephard

1 Like

Says above, had to be 3 before 4 heh, tried at 3 and at 4

and you have select him?

That’s who Lorn Lebam is Geezz why the 3rd degree?

@Wiese2007 is simply trying to determine why you are unable to promote your villager… we’re all on the same team here… :wink:

1 Like

thx steve ^^ at the moment im waiting at the trapper to test it ^^ perhaps the new promotescreen has some issues :wink: … at the moment i have found 2 issues with the ui system - so its possible ^^

correct… 3 ^^ hmmmz the last ui issue was critcal … no save possible and no select of anything -.- puhhhh only the ui has it kicked xD but it has saved ^^ nice the charaktersheet kicks the ui completly when you try to open the sheet via the symbol at next to the name at the bottom overview ^^


If at first you don’t succeed brew another pot of coffee. :coffee: :persevere:


sooooooooo after lots of reloads ^^ i can confirm it -

1 Like

Anyone tried it in 32bit mode?

good idea ^^ im at work …

me too, but getting off shortly. :sleepy:

hmmmm interessting at the first load of the promotion tree it was mirrored … now im waiting ^^

thanks for the confirmations folks… [tagged]

confirmed for x32 also ^^

Hmmmm… I wonder if this is why I can’t promote to my samurai class. . . . . :stuck_out_tongue_winking_eye:

1 Like

sooo i have a screenshot of the mirrowing tree ^^

looks nice ne :wink:

ok… i was redirected here by @SteveAdamo… thanks dude :D… but i can confirm this bug is still active, my trapper is currently level 3, and i have a shepherds crook in the stock pile… i click the trapper in the hearthling list and it wont let me promote with the text requirements not met, although my shepherds crook (although greyed out) is on the right side of the screen…

I am just creating a new world… this time i will put the pasture down before trying to make him a shepherd

Let’s see what happens



This might be part of the above bug… whenever i right click on my trappers name to see his char sheet, it de-focuses… but sometimes what will happen is the character sheet will show, literally for a split second… could some one please confirm this? thanks

i mean left click lol… ofcourse right click would defocus… facepalm but i honestly mean left click

update 2:

this bug still persists, here are my screen shots:

very annoying because now the game is virtually unplayable until this bug is fixed… i suppose you can play without a shepherd… but dont you need wool etc for all the materials the weaver needs to make? cheers

Please note these are not in order… i tried taking a screen shot of the achieved level 3 message, but i was too slow :frowning: this was going to be shown with the final screen shot in the list