[Res] Error on closing the promote window before animation finishes

resolved

#1

Tried to promote a trapper and nothing will happen, and you can’t select another villager to try again


#2

Can you go through this step by step please? I noticed in my b1658 game that the promotion UI is a little buggy if you try to close it before it closes itself, for example. Point is, the more info we have the better we can try to replicate it & pin the bug down :slight_smile: .


#3
  1. Open Village roster
  2. Select desired villager to promote.
  3. Select trapper and promote.
  4. Nothing happens, and profession tree error shows, and the trapper dagger is essentially useless.

#4

If you can reproduce the problem, please post a screenshot. Thanks!


#5

So I got it to work again, so I think its happening is I’m usually fast on my menu navgation so I usually close the job tree menu after I hit promote. I believe that was causing the error


#6

I’ve got the same problem but across careers. Each time comes up with an error message about promotion tree. Looked at the screenshot for Houten, same message.


#7

I’m getting the same error, but can promote a trapper (and everything else I’ve tried)…


#8

When I tried to promote a different civ it worked but not for others. Tried again just now it worked this time but I let the promotion screen close on its own rather press the close window X. So it could be down to a conflict caused by early closure of the window.


#9

WOO! Thanks for tracking this one down. I didn’t think to close the window before the animation completed. This will be fixed in the next build.


#10

Rapid Application Development folks… :smile: :+1:


#11

Just loaded up 1665, and this appears to be working fine :slight_smile: .


#12