[Con] Sunrise error see screen shot


#1

I believe this is caused by workers removing the log from the fire which is where it happened in the previous version of this bug. example have 2 hearths. worker will go light fire pick up burning log which will then go out fire continues to burn in hearth proceed to next hearth and use the same log to light fire then remove log and go build a wall or something with the log or place it back in the stock pile. they almost always pick up the log again after lighting the fire and do something with it. on the few occasions they haven’t picked the log back up i do not see this error.

edit attaching dxdiagDxDiag.txt (61.7 KB)


500 lua errors while playing
[Dup] Wall of Errors (Bug)
[Dup] Alpha 4: Assertion Failure on New Morning
Yet another unidentified error message
[Dup] [STEAM] [134] Error Message
[Dup] Error screen pops up during game - R134
#2

thanks for the screenshot and repro steps (even if they were a wee bit difficult to digest without any punctuation)… :wink:


#3

Confirmed for R118. Obviously also a confirmation of this bug, but that one was already confirmed.

23:16 fire can be seen without log. 23:58 sunrise error. Again: 36:35.

EDIT: actually, I’m no longer sure, as the wood block was again used at some point with morning subsequently coming with no error messages given.

Wood block taken after lighting it around 6:09 (see this post). Morning comes at 10:39; fire visible.

Perhaps the error messages are unrelated after all and just to do with morning coming sometimes? At any rate, it doesn’t correlate perfectly.


Impressions of Alpha 4 Release 118
#4

Alpha 4: Official Release

Game had an assertion failure just as the new morning dawned. I believe the assertion triggered immediately before the rooster crowed, although I wasn’t paying that careful attention, the error definitely appeared to be related to the start of the new day.

This was also almost immediately followed by a goblin appearing and stealing stuff, so I suppose it could be related to that.

Initial error is: radiant/lib/env.lua:6: assertion failed!

Here’s a screenshot:


#5

I think this is the same as this issue.


#6

It seems that din the middle of a game, I randomly got the below error wall. It did show up just as it turned day.


Post your Alpha 4 Screenshots!
#7

I can confirm this. Same circumstances


#8

First saw this on the dawn of day 7 in my R122 game.

31:21.


Impressions of Alpha 4 Release 122
#9

Summary: Error message occurred during the switch over from evening to daytime when the rooster called. This may of been related to the doubling up of the worker outfits on the weaver workbench that where stuck thee for duration of play.

Attachments:


Video upload:
First Error Window
Second Error Window


#10

hmm, i am pretty sure we have this report around here somewhere… searches

p.s. excellent work on the report format! :+1:


#11

Title:
Error screen pops up on the screen

Summary:
During the game a screen showed an error page

Steps to reproduce:
Could be many reasons…

  • New day
  • Ordering some crafting products with carpenter
  • Using the spoon
  • goblin attack
  • could also be a combo…

Expected Results:
Going from daytime to nighttime

Actual Results:
Going from daytime to nighttime with error screen

Mods added:
Why so Blue?

Attachments:

Sorry for english, not native english speaker :slight_smile:

First post btw! Happy Face


#12

The lines I can see don’t seem to suggest a mod issue - actually this pattern looks familiar to the calendar issues people get.

Yes:

Note it’s lines 3 & 510, as in your one, and in the same .luacs.

Unless I’ve missed something, I think @SteveAdamo should merge this with the linked thread. Also, I’m pretty sure @not_owen_wilson fixed this as well in the internal build :slight_smile: .


#13

Okay thanks for respons,

I searched for a while but some are similair but different… If the developers already knows this issue , this post can be deleted


#14

Ahem, of course it’s not a mod issue!! :wink:

But yes, it very much looks like the sunrise bug that Mr @not_owen_wilson and team have fixed internally!


#15

Is the fix for this problem in the next stable update?

Btw @Froggy big fan of the mod! keep up the good work!


#16

first of all, welcome aboard @Opperwezen! :smile:

second, your English is just fine… nice work on the bug report too! :+1:

finally… merged