[Con] r153 - Icons of recipe ingredients not always shown

resolved

#1

Bug:
When viewing recipes, icons for items needed are not always shown.

Summary:
When building the weaver’s spindle I had failed to notice there was the need for plants for thread. I had the plants harvested and delivered, however I had forgot to make thread. Then while double checking what I needed, noticed the missing icon.

Steps to reproduce:
At various steps the thread icon is missing in the required items, as shown in the screen shot document.

Work around tried:
It’s a play mechanic. Your guy has to figure it out kinda. It’s something from out side his specialty. Maybe if he was already level 2(?) with the co-op with other trades it would have shown. But later that failed when even after reaching the level it didn’t show up. (be a cool mechanic though)

Link to image:
imgur.com/nSdFD9a

Mod edit (embedded image):


#2

Just confirming this as I saw this same problem. I wasn’t sure exactly why it happens. I tried making sure my guy was the right level to craft the item, making sure that I had the item in a stockpile, and even crafting it and then checking to see if it updated.


#3

Can confirm this one as well. Note that mousing over the invisible icon did cause a regular tooltip to appear for me, so at least you can find out what’s required that way.


#4

When I made recipes and icons were not shown in the recipes list it was always fault of wrong image paths. That, or the icon doesn’t even exist.


#5

As far as I can tell, fixed in r156.