[Con] Can promote twice using the Carpenter Saw


#1

Issue: When you promote a citizen to a Carpenter, the saw itself is still selected and can be reused to try to promote another worker, though this action fails with with following error:

Expected Behavior: Once a talisman has been used to promote a worker it is no longer selected and can’t be ‘reused’.

Steps to Reproduce:

  1. Select Carpenter Saw
  2. Select Promote (‘1’ key)
  3. Select Worker, approve promotion
  4. Without select anything else, press ‘1’ again
  5. Click on another worker and approve the promotion.

-Will


#2

good catch!

the error log is certainly complaining that the talisman has already been “claimed”… and when you attempt to promote another unit, the value passed to the “promotion function” is likely null…


#3

Yay! I sometimes tried to make that, but never was enough fast. Or maybe because I didn’t use the shortcut key :sweat:

Good catch :+1: :smile:


#4

Yes, the ‘1’ key is the trick I think, though I’ll poke around a little more tonight (and double check if the trapper knife does the same thing). It doesn’t ACTUALLY double-assign the talisman, so it’s not too terrible a problem. :wink:

-Will


#5

I repro’d and the error keeps popping periodically, I can’t keep playing, they don’t follow my orders anymore x_x


#6

Ah, that explains the second issue I found (which I didn’t have time to type up last night); I tried to then setup the Carpenter workshop after getting that error and the carpenter wouldn’t do it… I’ll do some more research tonight, sounds like this is a bigger bug then I thought.

-Will


#7

Yep, got the same behavior; no response to any orders from my settlers after the double (triple, quadruple, etc) assign. I also CONFIRMED the same behavior with the Trapper’s Knife.

-Will


#8

Thanks for the information :smiley:
Probably the game tries to assign the non-existent amulet again and again, so it doesn’t respond to anything else…