[Con] [130] Villagers will not fight


#1

Just loaded an existing map in release 130, I had killed all the goblins I could see on the map before loading. When loaded there were 10-20 goblins waiting.

But the real problem is that when rallying the villagers will not fight. (footman also did not). Four villagers were inside a 25X40 building and one goblin. I “rally-ed” and un-rally-ed several times and nothing. The villager being attacked just covered it’s head, the others standing within 5-10 voxels stood in the “on guard” position but did not engage and when the first died the next attacked just covered it’s head.


#2

I experienced this a bit. The goblins that came were not close enough to the footman, who was patrolling the stockpiles, so he didn’t fight them. And then, when I told the settlers to attack instead, they fought him, but after receiving one hit they covered their head and ran. Fortunately they came back after a few seconds to support whoever was fighting the goblin after them.


#3

Did you by chance load a save that had ‘Incompatible save version’ written below it in red writing?

The reason I ask is that the scenarios that spawn goblins have a maximum squad size of 3, (4 including the thief) - I cant see how you have 10-20 goblins spawned unless you loaded an obsolete save.

If you did load a 130 save, then it would appear that it has been corrupted, which while unfortunate, would explain your issue.


#4

No “incompatible save warning” and I looked for it just to be sure.


#5

I ran into this in my latest video my citizens refused to fight goblins, I eventually had to promote two soldiers and the soldiers would fight; however the citizens still wouldn’t fight.


#6

We’re tweaking the radius of the combat sensor; if this happens again, could you post a screenshot so we can see how far they are from the goblins?

@Ramcat and @Krovikan can you confirm if this only happens on load?


#7

Youtube is currently processing the video I spoke of should be up soon. The farmers were right next to the goblins and being attacked by them, I clicked the defense button and they got in attack stance and then just sat there being beat up.

Edit: Also this happened a few moments after loading a old save (from r127), I tried saving it after loading it and reloading and same thing happened. Eventually I figured out soldiers would still attack. (Youtube says 44 minutes on my video processing)


#8

Issues presents itself from at the two minute mark.


#9

That video shows the behavior I was seeing but I did not have the “incompatible version” warning he did. I have not been able to replicate this problem except in the case of a lost villager one on one with a goblin. In that case about half the time I pressed the “rally” button the villager would fight, the other half it would just cover its head. The fight was in tall trees so I could not see everything going on.


#10

Maybe its a question not for here… but how come you guys are on buld 130? and if was on that would finally have a completed house?

Sorry for hijacking!


#11

hey there @markcumiskey… welcome aboard! :smile:

folks can take part and test the latest steam “unstable build” (in this case, 130) by following this guide:

http://stonehearth.net/2014/01/02/stonehearth-revision-12-now-available-on-steam/

edit: thanks for the video update @Krovikan! :+1:


#12

Than you very much!
Very Helpful!

edit: Unfrotunatly still no fix for building :frowning: always unfinished!


#14

Try building a new building see if it finishes, there is a chance that it gets stuck; however out of two builds I built in my most recent town one was complete one wasn’t. That was in r127 though that the building failed.


#15

We’re having some trouble reproducing this in build 130, any tips welcome.


#16

I haven’t been able to reproduce it, except in the one on one issue. I would consider it dead, until it happens to someone else or in the next version. Minus this, the new combat response of the villagers to run after a sighted goblin is a great improvement over R129.


#17

I’m not really sure how to reproduce it, after I loaded I was attacked right away then after that I didn’t get any goblins or caverns that I noticed. Actually commented later in the video I thought that was strange as I usually get 2-3 over and episode. So I don’t know if my game was in a bad state, I reloaded that game about 5-6 times off camera and the bug consistently happened.

Not sure if it was related to being a r127 save played in r130; if it was related to the goblins already queue by the engine when r127 was save or if it had none of the above issues.

I know in my r127 video this bug did not happen, infact I commented that my guys were overpowered in r127. I also linked my r127 video below if it can help.